Ads are able to deactivate popup blocker setting from preferences

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Howard van der Burgt, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:needinfo], URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This is happening more and more; ads seem to be able to change the popup blocker
setting within Tools-Options-Web Features. I have the Popup Blocker setting
always on but ads from some sites are able to deactivate it and therefore can
show their popups. Be aware this doesn't happen all the time, only certain ads
seem to be able to do this.

Reproducible: Sometimes
Steps to Reproduce:
1. Just go to the mentioned site
2. Try a few times if the effect doesn't show immediately
3.

Actual Results:  
A popup ad is shown which otherwise would be surpressed by the Firefox popup
blocker.

Expected Results:  
Firefox should not allow to have preferences changed programmatically.
Are you saying the site actually changes the app preference?  I can't replicate
this since the site seems to be down right now, but I'd have to see the script
that manages to "achieve" this without permission.
(Reporter)

Comment 2

13 years ago
In reply to Mike Connor:
Yes, that is exactly what I meant to tell. It is getting very annoying as I 
constantly have to check, after a visit to this site, if my popup blocker is 
still active. It might be the site or maybe one of the ads showing up there 
randomly who does this but I can assure you it does happen.
(Reporter)

Comment 3

13 years ago
There is one part of the site still working: http://search.suprnova.org/ 
I just went there and voila, my popup blocker setting was deactivated without 
scrupule.
I've got the same build on the same OS (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0) and the search.suprnova.org site
did not slip a popup through, nor did it change my preferences. I reloaded about
twenty times, appeared to see their entire current ad rotation more than once each.

grasping at straws: 
- what plugins do you have installed? (about:plugins)
- do you have Java installed, what version?
- do you have extensions installed?
Whiteboard: [sg:needinfo]
(Reporter)

Comment 5

13 years ago
I have installed:
1 extension: Tabbrowser extension 1.11.2004111302
Java runtime 1.4.2_05
Plug-ins:
Shockwave Flash 7.0 r19
Metastream 3
Java plug-in 1.4.2_05
Quicktime 6.5.1
Adobe Acrobat 6.00 for Netscape
Microsoft DRM network interface plug-in
Windows Media Player Plug-in Dynamic Link Library

I ran Spybot and Ad-Aware without results for something suspicious. I have 
running Mailwasher Pro 4, Kaspersky anti-virus 5, Skype.
It happens rather frequently and not only since Firefox 1.0 !
Maybe you have a host file which blocks certain ads companies ?
Please disable TBE and retry.  There has been reports of that extension causing
this problem.
(Reporter)

Comment 7

13 years ago
Will do and see if that cures it ! Damn shame of this extension if this is 
true ! Thanks for the info !
(Reporter)

Comment 8

13 years ago
I have disabled it and encountered no further unwanted popup ads. I then 
enabled it again and got an unwanted popup ad again so I suppose it is safe to 
assume it is indeed this tab-extension causing the problem. 
Sorry for the confusion, never thought that such extension could have caused 
this. I guess: STATUS=RESOLVED
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
TBE has a near-legendary reputation for being unstable

http://piro.sakura.ne.jp/xul/_tabextensions.html.en#problems
"This extension sometimes causes crush when you show popup menus, load webpages,
or operate tabs, because it intrudes into operations about loading pages,
showing popups, add/remove tabs, etc. Please don't use it if you would like to
use stable browser."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Group: security
(Reporter)

Comment 10

13 years ago
(In reply to comment #9)
> TBE has a near-legendary reputation for being unstable
> http://piro.sakura.ne.jp/xul/_tabextensions.html.en#problems
> "This extension sometimes causes crush when you show popup menus, load 
webpages,
> or operate tabs, because it intrudes into operations about loading pages,
> showing popups, add/remove tabs, etc. Please don't use it if you would like 
to
> use stable browser."

Yeah, but a shame it still is. I haven't used it since made aware of the 
troubles with it and I have had no further trouble. Firefox is my closest 
companion next to my wife (she doubts sometimes :-)) and I have no problems 
whatsoever with the other extensions like Webdeveloper, colorzilla etc. I have 
installed. It's an amazing piece of software and I hope it will survive and 
evolve like nothing else.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.