input type=file extends beyond the end of a table

RESOLVED DUPLICATE of bug 132565

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 132565
13 years ago
13 years ago

People

(Reporter: Andrés Adrover, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the page at http://www.cmp.es/ppm/indice.php I have introduced a file upload
dialog in the top form.  This file upload dialog is restricted to a width of 300
pixels and a height of 17 pixels through the following markup.
style="WIDTH: 300px; HEIGHT: 17px; BACKGROUND-COLOR: #ffffff">
This input field extends past the edge of the table.

In the next form the input=text with the same style displays correctly?

On a related note which I do not have enough information to know if it's a bug
or a feature I would like the two forms to appear centered.

I enclosed everything in a 
< div align="center"

Do you know any references (i.e. RTFMs) that show how to achieve the desired
layouts with firefox and mozilla?

By the way Mozilla 1.7.3 for windows on Windows 2000 displays the same behaivour.

Reproducible: Always
Steps to Reproduce:
1. Navigate to http://www.cmp.es/ppm/indice.php
2.
3.

Actual Results:  
The Browse button of a file upload form field extends past the end of a table.

A page that should appear centered does not appear centered.

Expected Results:  
It should have displayed the form field within the table.

I am too much a lamer to know how to change the theme.  I suppose I have to
restart the browser.  I am currently using Noia Extreme 2 as the theme but
Mozilla 1.7.3 shows the page exactly the same way.
Assignee: bugs → nobody
Component: Form Manager → Layout
Product: Firefox → Core
QA Contact: firefox.form-manager → core.layout
Version: unspecified → Trunk

Comment 1

13 years ago
Setting a file input's width is broken, bug 132565. The page is not centered 
because you have set a fixed width for <body>. Centering a 500px wide table on a 
500px wide body doesn't do much...

*** This bug has been marked as a duplicate of 132565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.