Closed Bug 272596 Opened 15 years ago Closed 15 years ago

Text in table in absolute positioned div with auto width doesn't wrap

Categories

(Core :: Layout, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041128 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041128 Firefox/0.9.1+

See upcoming testcase.
You can see the bug at the url when hovering over the bottom image links.
A popup should come up. Hover over the image "Dane Electric". All the text is
one one line, but it should wrap over several lines.

This seems to be a regression.
I don't see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041126
Firefox/0.9.1+ 7:42am
I can see the bug, using;
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041127
Firefox/0.9.1+ 7:48am
I suspect the fix for bug 201897 might have caused this.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Attached file Testcase
Pressing "Button 1" is what seems to have regressed.
Pressing "Button 2" is what never seemed to have worked (but should, imho -
ignore this if this has got nothing to do with the bug).
Keywords: regression, testcase
The last patch from bug 201897 seems to have fixed this bug.
With a 2004-12-05 trunk build I can see the bug, but not anymore with a
2004-12-06 trunk build.
Pressing "Button 2" still doesn't work however, but that never worked and is
probably a different problem.
(In reply to comment #2)
> Pressing "Button 2" still doesn't work however, but that never worked and is
> probably a different problem.

Looks like a pure table bug - filed bug 275178.

Other than that, the testcase and site works fine now after we changed the fix
for bug 201897 to a less aggressive one.

-> FIXED
Status: NEW → RESOLVED
Closed: 15 years ago
OS: Windows 2000 → All
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.