random crash while browsing

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Arthur Kinser, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

1.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Whe three or more tabs are opened and I start opening new pages, it just closes
and then an errror report is generated that is sent to the windows error
reporting utility site.

Reproducible: Always
Steps to Reproduce:
1.open three or more windows
2. progress to links from those pages
3.it shuts down after from 1 Minute to 5 minutes

Actual Results:  
the error reporting window opened and when it completes sending the error to
windows, firefox closes.

Expected Results:  
Stayed open.

I would like to send a JPG where I combined some of the windows that I gotr
usinf a screen capture utility.  How do I attach these .JPG's?  Please send mwe
an e-mail and I will send these back as an attachment.  I do not have any virus's.
(Reporter)

Comment 1

13 years ago
Created attachment 167560 [details]
these are the open apps that are in use when the error happens.

This is a screen capture with the open apps that are in use when firefox closes
unexpectedly.
(Reporter)

Comment 2

13 years ago
Created attachment 167561 [details]
some of the 87 sections of the error report

this is a conglomeration of the error message I get.
Did you installed extensions ? 

Comment 4

13 years ago
Could you install a build with Talkback send a Talkback report and post its ID
here? See <http://kb.mozillazine.org/Talkback>.
Works fine for me obviously.
Keywords: crash
Summary: when multiple tabs are open, the browsert shuts down and an error report opens to the windows site. → random crash while browsing
Version: unspecified → 1.0 Branch

Comment 5

13 years ago
I've also experienced this problem on Windows XP SP1, Firefox 1.0.1, never had
an issue with 1.0.

If I open *MORE* than 3 tabs, and 2 or more of them are simultaneously active,
the browser engine locks up, the animations stop, I can still however switch
tabs and so on, clicking reload has no effect even on the tabs that weren't
active at the time.
When the window is closed the process remains and must be forcibly killed.

Comment 6

13 years ago
Created attachment 176345 [details]
This is a screencap showing the extensions I have installed

This is a screencap showing the extensions I have installed.

I did have to completely remove and re-install FlashBlock when I upgraded to
1.0.1 but I think this is normal.
we need a talkback ID

Comment 8

13 years ago
I have turned talkback on and thus far have been unable to replicate the bug
(and it's not for lack of trying) I will reply again if/when the next crash
occurs with the talkback ID.

Comment 9

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050322
Firefox/1.0+

Trying to confirm on latest nightly.  

Just a note, before I go on, you realize you have an /insane/ amount of
processes running, right?  I can't read the screenshot all that well, since your
choice of 'customized' Windows theme is a little hard on the eyes, but I can
identify at /least/ 6 different 'suspect' processes running.  I'm not going to
say that it might be something running in the background, or perhaps
'customization' of an already unstable desktop environment that might be causing
crashes, but at any rate, on with my testing.

Following the steps to reproduce, I opened 3 seperate instances of Firefox
"windows", and had different websites in each one. 

No problems whatsoever, behavior as expected.

Marking this Resolved WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 10

13 years ago
Morgan and Arthur, if either of you come up with a Talkback ID and/or more
indepth steps to reproduce, file a new bug.
You need to log in before you can comment on or make changes to this bug.