TB nightly 12/01/04 comes up blank (/thunderbird/nightly/latest-trunk only)

VERIFIED FIXED

Status

Thunderbird
Mail Window Front End
--
blocker
VERIFIED FIXED
14 years ago
8 years ago

People

(Reporter: wsmwk, Assigned: dmose)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

20041128 was working fine.
installed nightly 12/01 in it's own directory to upgrade and it comes up blank

Reproducible: Always
Steps to Reproduce:
1. download nightly 12/01/04
2. install
3. start TB

Actual Results:  
Blank UI (see attachment)

Expected Results:  
populated 3 pane view

related to bug 252127 ?
(Reporter)

Comment 1

14 years ago
Created attachment 167565 [details]
Blank TB screen

Comment 2

14 years ago
I see this too on Linux. Confirming and marking OS as All. Also raising the
Severity to blocker. I've looked and looked but was unable to find an existing bug.
Severity: critical → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

14 years ago
This bug is caused by the packaging manifest putting xbl bindings in mail.jar,
so those bindings are now being used rather than the ones in toolkit.jar.

The compose window is also complaining about missing charset entities. 
messengercompose.xul tries to use charset.dtd, but that dtd wasn't merged into
the trunk from the aviary branch.
(Reporter)

Comment 4

14 years ago
Created attachment 167832 [details]
TB screen in winXP home
(Reporter)

Comment 5

14 years ago
>This bug is caused by the packaging manifest putting xbl bindings in mail.jar,
>so those bindings are now being used rather than the ones in toolkit.jar.

Great research - I know nothing about these things. FWIW I don't see any open or
recently changed packaging bugs, nor anything mentioning mail.jar or toolkit.jar 

more research 
* environment is IMAP
* no dups or bugs found that may be remotely related 
* (installer reports "Installing TB version 0.6.0+" - what's up with that?)

firstly, on w2k ...
* original reported problem on windows 2000
* per screen shot attachment 167565 [details] the only text in the window are the words
"view" and "folders" - no menus, folders, mail nor splash screen

on winXP ...
just installed nightly 12/01 on winxp home with similar results, but not
identical per attachment 167832 [details]
* TB operating OK in "a few" respects
  - TB startup splash screen panel
  - folders panel
  - toolbar widgets display
  - address book (but no command menu line)
  - detects new mail (unread count changes)
  - all IMAP folders clickable under "Folders" but nothing appears in "view" panel 
* however
  - view panel is empty and incapable of displaying any messages
  - not prompted for my mail password at TB startup
  - "N" takes me from mail to first unread newsgroup, but does not display
unread mail
  - write new message = "an error occurred while creating a message compose window"
  - no text in the command menu bar 
  - "search for messages" panel can be started, but comes up blank

bug 272744 and bug 272530 may be unrelated as they are different platforms and
symptoms, but a bit coincidental that they are reported at the same time

Installed 12/03 nightly build on XP machine - similar results with this
exception, "write new message" results in a window containing "<menu
id="maileditCharsetMenu" label="&charsetMenu.label;"
accesskey="&charsetMenu.accesskey;" datasources="rdf:charset-menu" ...

(I'd report the build numbers but, well, help>about is not accessible)
(In reply to comment #5)
> (I'd report the build numbers but, well, help about is not accessible)
On MS Windows, you can know it through property of thunderbird.exe.
 Property of thunderbird.exe -> Version (Information) -> Product Version

Problem still occurs on 1.8a6: 2004120405 build of nightly/latest-trunk(Win-2K).   
  http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly
        /latest-trunk/thunderbird-win32.zip (timestamp=04-Dec-2004 15:37)
(Assignee)

Updated

14 years ago
Hardware: PC → All
As I wrote in Bug 272744 Comment #5, problem on 2004/12/01 was ;
 http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly
       /latest-trunk/thunderbird-win32.zip (1.8a6: 2004120107)
> XML Parsing Error: undefined entity
> Location: chrome://mozapps/content/profile/profileSelection.xul
> Line Number 42, Column 10:
>  title="&windowtitle.label;"
> --------^
But above has already disappeared, then problem is this bug now, same problem as
attachment 167565 [details], on 1.8a6: 2004120405 (win-2K).

What's going on in Thunderbird trunk?
Who is doing it? 

Comment 8

14 years ago
no one is doing anything with the thunderbird trunk.

We're busy trying to ship 1.0.

I'm sure the trunk is very broken after the firefox 1.0 landing last week for
tbird. We probably won't start looking into these issues until we've released.
Sorry!
(In reply to comment #8)
> no one is doing anything with the thunderbird trunk.
> We're busy trying to ship 1.0.
> I'm sure the trunk is very broken after the firefox 1.0 landing last week for
> tbird. 

Oh I see. Probably result of intermittent preparation work for merging. 

> We probably won't start looking into these issues until we've released.
> Sorry!

Not at all.
I do not use latest-trunk until normal work will start again.
I continue to use latest-0.9 for verification test of your great patchs.

By the way, Mscott, thanks for resolving lo---nglived "#" problem in addition to
more lo---nglived "/" and '?" problem :-) 
Summary: TB nightly 12/01/04 comes up blank → TB nightly 12/01/04 comes up blank (/thunderbird/nightly/latest-trunk only)
(Assignee)

Comment 10

14 years ago
Created attachment 168654 [details] [diff] [review]
patch v1

Patch based on sdwalker's comment.  Seems to work nicely.
(Assignee)

Updated

14 years ago
Attachment #168654 - Flags: review?(mscott)

Comment 11

14 years ago
Comment on attachment 168654 [details] [diff] [review]
patch v1

thanks dan.
Attachment #168654 - Flags: superreview+
Attachment #168654 - Flags: review?(mscott)
Attachment #168654 - Flags: review+

Comment 12

14 years ago
uumm... So as far as I can tell the patch hasn't been checked in. Is there any
reason why?
(Assignee)

Updated

14 years ago
Assignee: mscott → dmose
(Assignee)

Comment 13

14 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

14 years ago
I just backed myself out.  Turns out that mscott landed a different and better
fix for this in the interim by pointing the XUL towards the charsetOverlay.dtd
that's already included in the toolkit.

Comment 15

14 years ago
The packaging manifests (my earlier comment about toolkit.jar can be ignored; I
had forgotten that toolkit.jar does not get shipped) are still somehow horking
builds.  Can anyone (Pratik, others?) reproduce the "blank"ness issue shown in
the screenshots on platforms other than Windows?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 16

14 years ago
(In reply to comment #14)
> I just backed myself out.  Turns out that mscott landed a different and better
> fix for this in the interim by pointing the XUL towards the charsetOverlay.dtd
> that's already included in the toolkit.

I'm not seeing it in the nightlies.  Are you referring to what he landed on 12/20?

(Reporter)

Comment 17

14 years ago
*** Bug 275798 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
(In reply to comment #15)
> Can anyone (Pratik, others?) reproduce the "blank"ness issue shown in
> the screenshots on platforms other than Windows?

I see the "blankness" on Linux with todays build (2004-12-22).
(Reporter)

Comment 19

14 years ago
(In reply to comment #16)
> (In reply to comment #14)
> > I just backed myself out.  Turns out that mscott landed a different and better
> > fix for this in the interim by pointing the XUL towards the charsetOverlay.dtd
> > that's already included in the toolkit.
> 
> I'm not seeing it in the nightlies.  Are you referring to what he landed on 12/20?

My lame comment was meant to mean I don't see a fix affecting the 12/22 nightly.
The bug is still there.  

If the landing happened a couple days ago wouldn't it have hit the nightly?  
Is there a different bug# that mscott was addressing?

Version: unspecified → Trunk
(Reporter)

Comment 20

14 years ago
WFM TB version 0.6+ (20050110) 1.8a6: 2005011014

Dan, Mscott, do we mark resolved by a checkin for this bug?  Or as a dup, eg bug
276918?

Comment 21

14 years ago
let's just re-resolve it as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

14 years ago
marking this VERIFIED.

This should be a differnt bug, but ...

interestingly, just yesterday 4/2/05 TB stopped processing new mail, and
continued not working for about 24 hours. 

I restarted TB, all I got was the command menu items (ala as reported in this
bug) but nothing works and of course no mail is shown.  I restarted a couple
times and same problem.  Tried again today and finally it "woke up" - everything
displays and works.

So it's strange - I have not changed my version of TB in months and I did not
delete any files in the profile to get this to work again.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.