Remove All Styles should work for all text attributes, not just B,I,U

VERIFIED FIXED in M16

Status

()

Core
Editor
P1
major
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: Joe Francis)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Composer feature work)

(Reporter)

Description

19 years ago
Current implementation of this loops 3 times through RemoveInlineProperty
for B, I, and U. First, this ignores all other inline HTML attributes.
Second, it is inefficient. We should make nsHTMLEditor::RemoveInlineProperty
remove all inline attributes during the same iteration search through nodes
in the selection.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 1

19 years ago
it doesn't even work for B, I, U
(Reporter)

Comment 2

19 years ago
Also, using this to turn off all text attributes at a collapsed selection
(caret point) needs work. It currently doesn't work at all. I tried changing
attribute names from 'B', 'I', and 'U' to 'b', 'i', and 'u', and then it acted
strange: Using command in bold text did turn of bold, but it turned on italic
and underline! This needs investigation.
(Reporter)

Comment 3

19 years ago
*** Bug 26994 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

19 years ago
Joe says he was planing on doing this. We need to replace existing JS with
an nsEditor::RemoveInlineAttributes() (or some name like that.)
It should "remove all inline nodes that are also containers" as Joe says,
but it should NOT remove <a>, i.e., links.
Assignee: cmanske → jfrancis
Status: ASSIGNED → NEW
(Reporter)

Comment 5

19 years ago
Joe: After you implement the nsEditor method, please use it to change
nsEditorShell::RemoveTextProperty() for the case when "prop" = "all".
Or you can reassign this to me and I'll fix up that code.
(Reporter)

Updated

19 years ago
Blocks: 28969

Comment 6

19 years ago
moving to M16
Target Milestone: M15 → M16

Comment 7

19 years ago
updating keyword and status whiteboard to reflect that this is a beta 2 feature 
work bug that the Composer team deems a must fix for beta 2.
Severity: normal → major
Keywords: beta2
Priority: P3 → P1
Whiteboard: Composer feature work
(Assignee)

Comment 8

19 years ago
i accept Bugzilla as my lord and savior.  
Status: NEW → ASSIGNED
(Assignee)

Comment 9

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Keywords: nsbeta2

Comment 10

19 years ago
verified in 4/26 build.
Status: RESOLVED → VERIFIED
Keywords: beta2
You need to log in before you can comment on or make changes to this bug.