Firefox crashes with this javascript code [@ js_Mark - js_MarkGCThing]

RESOLVED DUPLICATE of bug 203278

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 203278
13 years ago
4 years ago

People

(Reporter: Aaron Slunt, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0

WARNING: this code will crash firefox.exe. Don't go here if you have anything
important you're currently working on in it.

That script continuously generates a new array and sorts it. Firefox crashes
after a few seconds on a page like this. Monitoring task manager, Firefox got up
to the limit that I had set for memory capacity, and then immediately crashed.
On a few occasions, my clipboard was wiped out as a result of this.

I don't know what exactly should be done about it, but it does crash firefox and
I consider this a bug.

Reproducible: Always
Steps to Reproduce:
1.Go to the URL above with javascript enabled.
2.
3.
Confirmed crash on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Talkback ID:
2305842
Created attachment 167611 [details]
Testcase

Testcase that crashes:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041201
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041201
Firefox/1.0+

Although not consistently. Various combinations of old/new profiles seem to
skew the results. Another TBID that seems different is 2306134.

Comment 3

13 years ago
Date/Time:      2004-12-01 20:57:31 -0800
OS Version:     10.3.6 (Build 7R28)
Report Version: 2

Command: Camino
Path:    /Applications/Browsers/Camino.app/Contents/MacOS/Camino
Version: 0.8+ (0.8+)
PID:     14081
Thread:  0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0xbf802fc0

Thread 0 Crashed:
0   libmozjs.dylib        	0x0603f554 js_Mark + 0x10
1   libmozjs.dylib        	0x060273e8 js_MarkGCThing + 0x88
2   libmozjs.dylib        	0x06027438 js_MarkGCThing + 0xd8
...
508 libmozjs.dylib        	0x06027438 js_MarkGCThing + 0xd8
Assignee: firefox → general
Component: General → JavaScript Engine
Keywords: crash
Product: Firefox → Core
QA Contact: firefox.general → pschwartau
Summary: Firefox crashes with this javascript code → Firefox crashes with this javascript code [@ js_Mark - js_MarkGCThing]
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 203278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ js_Mark - js_MarkGCThing]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.