Personal Address Book list is empty after switching to Collected Addresses

VERIFIED FIXED in Thunderbird1.0

Status

Thunderbird
Address Book
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: J. Carlos Navea, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird1.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When composing a new e-mail message and viewing the Contacts list via the
Contacts button on the e-mail composer window, if you switch to the Collected
addresses option and this list is empty and then switch back to the Adress book
option, the original Address book list is no longer there, the list is empty.
You need to hide the Contacts side panel and show it again to get the Address
book list back.

Reproducible: Always
Steps to Reproduce:
1. Write new e-amil
2. Click on the Contacts button on the new e-mail window
3. Under Address Book: choose "Collected Addresses"
4. Switch the Address Book selection back to "Address Book"

Actual Results:  
The original Address Book list is empty

Expected Results:  
The Address Book should not be empty, it should display the contacts that are
displayed when the window is originally opened.

version 1.0RC1 (20041201)

Comment 1

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> 
> When composing a new e-mail message and viewing the Contacts list via the
> Contacts button on the e-mail composer window, if you switch to the Collected
> addresses option and this list is empty and then switch back to the Adress book
> option, the original Address book list is no longer there, the list is empty.
> You need to hide the Contacts side panel and show it again to get the Address
> book list back.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Write new e-amil
> 2. Click on the Contacts button on the new e-mail window
> 3. Under Address Book: choose "Collected Addresses"
> 4. Switch the Address Book selection back to "Address Book"
> 
> Actual Results:  
> The original Address Book list is empty
> 
> Expected Results:  
> The Address Book should not be empty, it should display the contacts that are
> displayed when the window is originally opened.
> 
> version 1.0RC1 (20041201)

Exact the same bug here.

I shows up with the Thunderbird 1.0RC1 , it did NOT happen with any previous
version. It's reproducible in exact the same way. It's not limited to just
personal or collected address book, but to all address books listed. Closing the
 Conctacts panel and opening it again (or just close an open Compose: window) is
needed to make it show up again. It is possible to correctly search for unlisted
addresses and see the search result, the normal books just don't show up.



also: this bug may be moved to "Message Compose Window" category instead
(Assignee)

Comment 2

14 years ago
david and i see this too
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird1.0
OS: Windows 2000 → All
(Assignee)

Comment 3

14 years ago
Created attachment 167691 [details] [diff] [review]
the fix
(Assignee)

Comment 4

14 years ago
Comment on attachment 167691 [details] [diff] [review]
the fix

DirPaneSelectionChangeMenulist	was a routine we were picking up from the
seamonkey address picker dialog and it wasn' designed to work with the contacts
side bar at all so I replaced it with our own method. 

I made this work such that quick search text is preserved across a change in
directories in the contacts bar. 

i.e. if I type 'Scott' then switch from the AB to an LDAP directory, we do an
LDAP search on Scott. Change back to an adddress book and see a search of that
abook that matches 'Scott'.
Attachment #167691 - Flags: superreview?(bienvenu)

Updated

14 years ago
Attachment #167691 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 5

14 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
*** Bug 272765 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
verified with Windows build 2004-12-03-06-0.9
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.