Weird compose editor behaviour

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
13 years ago
13 years ago

People

(Reporter: Tim Drijvers, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Thunderbird/1.0RC1 (20041201)

When i set the default font-type to Helvetica and use a bulleted list the
font-type and font-size will be changed to 

Reproducible: Always
Steps to Reproduce:
1. Tools->options 
2. Composition->HTML options
3. Set the default font to "Helvetica, Arial" size: "small"

4. Click "Write" (write a new message)
5. Click "Apply or remove bulleted list"
6. Typ a random text
Actual Results:  
Now you'll note that the font-style and font-size have been changed to "Variable
width" and "medium"

Expected Results:  
Expected that the font-type and font-size will be the same ("Helvetica, Arial"
size: "small")

Also possible to reproduce in an other way:
1. Tools->options 
2. Composition->HTML options
3. Set the default font to "Helvetica, Arial" size: "small"

4. Click "Write" (write a new message)
5. Write a random text (note that the font is "Helvetica")
6. Select the current line and click "Apply or remove bulleted list"
7. Press enter, an other bullet appears. Write an other random line of text
8. Press double enter to leave the list
9. Typ some more text (not bulleted). Now you'll note that the font-style and
font-size have been changed to "Variable width" and "medium"

Comment 1

13 years ago
As noted at the dupe: the workaround is write at least one character of text 
before changing the paragraph style.

*** This bug has been marked as a duplicate of 250539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.