Virtual Folders threaded view does not persist across focus changes.

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: elliot.turner, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999

Build Identifier: version 1.0RC1 (20041201)

A threaded view may be configured for a virtual folder (saved message search). 
However the threaded view preferences do not persist across focus changes (when
another folder is viewed, then the virtual folder is viewed again).  

Non-virtual folders persist threaded view preferences across focus changes
without problems.


Reproducible: Always
Steps to Reproduce:
1.Create a folder from a saved message search, for example a saved search for
subject line "Fw:"
2.Bring focus to this folder, viewing its contents.
3.Select pulldown menu option "View->Threads->All".
4.Select pulldown menu option "View->Sort By->Threaded"
5.Notice that the virtual folder view is now threaded.
6.Change mouse focus to another folder, viewing its contents.
7.Change mouse focus back to the virtual folder.

Actual Results:  
The virtual folder view no longer shows in a threaded fashion.

Expected Results:  
The virtual folder should show itself in a threaded fashion, persisting view
configuration as normal non-virtual folders do.

Comment 1

14 years ago
(In reply to comment #0)
> A threaded view may be configured for a virtual folder (saved message search). 

I don't see this happening.  How did you get to this point, given your report of 
bug 272759?

> However the threaded view preferences do not persist across focus changes

I do see that the  View | Threads  selection clears (reverts to no item 
selected).

> Steps to Reproduce:
> 1.Create a folder from a saved message search, for example a saved search for
> subject line "Fw:"
> 2.Bring focus to this folder, viewing its contents.
> 3.Select pulldown menu option "View->Threads->All".

Which causes the display to clear, as noted in the other bug.

> 4.Select pulldown menu option "View->Sort By->Threaded"
> 5.Notice that the virtual folder view is now threaded.

How can I notice this if no items are displayed?


I'm marking this bug Invalid for now, since the capability of threading virtual 
folders is unimplemented -- bug 263180.  When and if that feature is completed, 
new bugs should be filed if this or similar symptoms occur then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.