Closed Bug 272765 Opened 17 years ago Closed 17 years ago

No more contact displayed in contacts sidebar after switching address book

Categories

(Thunderbird :: Message Compose Window, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 272720

People

(Reporter: jerome, Assigned: mscott)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.5) Gecko/20041111 Firefox/1.0 (Debian package 1.0-2)
Build Identifier: Thunderbird 1.0RC1

When composing a message with contacts sidebar enabled, if you switch the
address book with the drop down menu (between "Personnal address book" and
"Collected addresses" for example), no more contact appears in the list. If you
switch back to the previous address book, no more contact appears in the list.

Reproducible: Always
Steps to Reproduce:
1. Open the compose message window
2. Display the contacts sidebar, contacts should be listed
3. Switch the address book from "Personnal address book" to "Collected addresses"

Actual Results:  
No contact appear in the list

Expected Results:  
Contacts should be listed in the list
I see this too.  0.9 and recent nightlies (I think I was running 1126 before) 
did not do this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
This happens also with TB 1.0 RC1.

If I switch to another address book category, address list is just cleared.

Now if I restart TB, and then go instantly to compose/forward I can see email 
addresses correctly, but if I switch to another category then it is again 
cleared. So I have to use that address book window to get addresses or restart 
TB to send email. 

I would suggest that this would be fixed before TB 1.0 as this is one of the 
most annoying problems with it.

*** This bug has been marked as a duplicate of 272720 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.