page must be reloaded before repeating background .gifs are drawn

RESOLVED FIXED

Status

()

Firefox
General
--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Michael O'Henly, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Screenshots at http://cuppanews.com/images/pub/ffbug01.gif and ffbug02.gif.
Page is displayed with repeat-y tiled background .gifs that produce the "faux"
left, middle, and right columns. Must manually reload the page in order for the
background .gifs to display. Page is set to refresh every 240 sec. using "<meta
http-equiv="Refresh" content="240"/>" and problem occurs each time it does so.
Also occurs first time page is loaded from bookmark.

Reproducible: Always
Steps to Reproduce:
1. Load page. OR...
2. Allow page to refresh (every 240 sec.)
3.

Actual Results:  
The screen appears as shown in ffbug01.gif, without the repeating tile
background in each of the columns. 

Expected Results:  
After manually reloading the page, it appears (correctly) as shown in ffbug02.gif.

HTML is generated using ExpressionEngine. Site is in development. If you need
live access, please let me know and I'll set something up.
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> 
> Screenshots at http://cuppanews.com/images/pub/ffbug01.gif and ffbug02.gif.
> Page is displayed with repeat-y tiled background .gifs that produce the "faux"
> left, middle, and right columns. Must manually reload the page in order for the
> background .gifs to display. Page is set to refresh every 240 sec. using "<meta
> http-equiv="Refresh" content="240"/>" and problem occurs each time it does so.
> Also occurs first time page is loaded from bookmark.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Load page. OR...
> 2. Allow page to refresh (every 240 sec.)
> 3.
> 
> Actual Results:  
> The screen appears as shown in ffbug01.gif, without the repeating tile
> background in each of the columns. 
> 
> Expected Results:  
> After manually reloading the page, it appears (correctly) as shown in ffbug02.gif.
> 
> HTML is generated using ExpressionEngine. Site is in development. If you need
> live access, please let me know and I'll set something up.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
> 
> Screenshots at http://cuppanews.com/images/pub/ffbug01.gif and ffbug02.gif.
> Page is displayed with repeat-y tiled background .gifs that produce the "faux"
> left, middle, and right columns. Must manually reload the page in order for the
> background .gifs to display. Page is set to refresh every 240 sec. using "<meta
> http-equiv="Refresh" content="240"/>" and problem occurs each time it does so.
> Also occurs first time page is loaded from bookmark.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Load page. OR...
> 2. Allow page to refresh (every 240 sec.)
> 3.
> 
> Actual Results:  
> The screen appears as shown in ffbug01.gif, without the repeating tile
> background in each of the columns. 
> 
> Expected Results:  
> After manually reloading the page, it appears (correctly) as shown in ffbug02.gif.
> 
> HTML is generated using ExpressionEngine. Site is in development. If you need
> live access, please let me know and I'll set something up.

Apologies. The ffbug01.gif screenshot shows the _correct_ rendering of the page.
The ffbug02.gif screenshot shows the error.

There is a single gif (http://cuppanews/images/images/cn_images/bgTile.gif) that
produces the effect of a tiled repeat-y background for each of the columns.

I did have a javascript attached to the page (nicetitle.js) which I've since
disabled. The problem is still there. The problem doesn't exist in IE6 (with or
without the javascript).

Comment 2

13 years ago
Can please you provide us with a url, or a testcase so that this can be
investigated.
(Reporter)

Comment 3

13 years ago
Thank you for the quick response.

I've set up a test case for you at
http://cuppanews.com/images/pub/testcase/index.html. I'm using the HTML
generated by ExpressionEngine and the same CSS as in the "real" site. The page
in this test loaded correctly, but after the first refresh, showed the problem
I've described. I'd suggest loading it, leaving it for the first refresh (240
seconds), and then checking it.
(Reporter)

Comment 4

13 years ago
Just realized now that, now only is the "wrapper" div bkgd not being redrawn,
but neither is the border or bkgd of the "footer" div.

Comment 5

13 years ago
Yeah I'm seeing this too. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
(Reporter)

Comment 6

13 years ago
Sorry, I managed to screw up the test case. Until I fix that, I've opened up
access to the "real" site. Just go to http://cuppanews.com.
(Reporter)

Comment 7

13 years ago
OK, test case is fine now (http://cuppanews.com/images/pub/testcase/index.html).
I'm turning off access to "real" site so that I can get back to work on it.
Sorry again for the interruptions!

Comment 8

13 years ago
I experenced this problem with Firefox 1.0 but not with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041201
Firefox/1.0+

Which means it has allready been fixed in the trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

13 years ago
Thanks for the followup. I'll look forward to seeing this fix in the next
release of Firefox.
You need to log in before you can comment on or make changes to this bug.