If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Forwarded message containing remote images loads images automatically

VERIFIED WORKSFORME

Status

Thunderbird
Mail Window Front End
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Gordon Tyler, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Thunderbird version 0.9 (20041103)

When a message that has remote images is forwarded as an attachment, the
resulting message when viewed loads the remote images for the inline
representation of the attached message, regardless of the setting to block
loading of remote images in mail messages.

Reproducible: Always
Steps to Reproduce:
1. Forward an email containing remote images to yourself as an attachment.
2. View the resulting email when it arrives.


Actual Results:  
The remote images are loaded and displayed in the inline representation of the
attached message.

Expected Results:  
The remote images should have been blocked according to the security setting and
the same option to load remote images should be provided if images are blocked.

Comment 1

13 years ago
Created attachment 168507 [details]
Msg w/ attached message w/ <img> w/ remote href

I am unable to reproduce this problem.	This attachment is a (text/html) email
message with a message/rfc822 attachment.  That attachment is also a text/html
message, with an <img> tag pointing to a remote image.

When I load this message up in Thunderbird, the image is blocked until I click
the Show Images button.

Comment 2

13 years ago
Bug 263345 is, if not duplicate, at least very related to this one.

Comment 3

13 years ago
(In reply to comment #2)
> Bug 263345 is, if not duplicate, at least very related to this one.

Possibly.  Gordon Tyler, are the images actually included in the forwarded 
messages, or are they still being referenced remotely?  Per that bug, remote 
images are loaded into the compose window during reply/forward operations; in 
that case, they are sent on as parts (attachments) rather than remote images and 
so will not be blocked by the receiver.  Is that what you're seeing?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Possibly.  Gordon Tyler, are the images actually included in the forwarded 
> messages, or are they still being referenced remotely?

I just tested it again. I have an email from Apple's iTunes store which is about
56K and has remote images (I doubled checked the source). I forwarded it to
myself as an attachment and when the forwarded message arrived, the images
loaded as soon as I opened the message. The forwarded message is also about 56K
and does not contain embedded images -- they are still be loaded remotely.

Note that I am forwarding the message as an attachment, not inline. So the
composer only deals with the message as an attachment, not as inline HTML with
images.
(Reporter)

Comment 5

13 years ago
I forgot to mention that I've reproduced the bug with Thunderbird 1.0 build
20041206.

Comment 6

13 years ago
Have you set the preference under Options | Advanced for
  [] Allow remote images if the sender is in [address book]    ?

And do you have a card in your address book for yourself?
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> Have you set the preference under Options | Advanced for
>   [] Allow remote images if the sender is in [address book]    ?
> 
> And do you have a card in your address book for yourself?

Aha, yes, that was it. Once I turned off that option, the images didn't load.

Sorry for the bother.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.