Installation fails from missing xpcom_core.dll

VERIFIED FIXED

Status

()

Firefox
Installer
--
blocker
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: tracy, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({smoketest})

Trunk
x86
Windows XP
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
seen on Windows Firefox trunk build 2004-12-02-12-trunk

-Use the installer bits and go through default selections in the setup dialogs.
As soon as the installation begins it throws a dialog about missing
xpcom_core.dll.  Attempt to reinstall as suggested by the dialog results in the
same missing file.
(Reporter)

Comment 1

14 years ago
Created attachment 167679 [details]
Dialog thrown at beginning of installation
(Reporter)

Comment 2

14 years ago
Created attachment 167680 [details]
2nd dialog

Dialog uncovered when dismissing missing dll dialog

Comment 3

14 years ago
Dupe of bug 272851 (or vice-versa)? Either way, I can confirm seeing this as well.

Comment 4

14 years ago
*** Bug 272851 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
(In reply to comment #3)
> Dupe of bug 272851 (or vice-versa)? Either way, I can confirm seeing this as well.

I duped my bug to this one since this one has the screenshots of the problem.

Comment 6

14 years ago
you probably just need to re-add xpcom_core.dll to the firefox packaging manifests.
This no longer occurs in latest tinderbox builds.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

14 years ago
Verified fixed with windows FF Trunk build 2004-12-03-06-trunk
Status: RESOLVED → VERIFIED

Updated

14 years ago
Keywords: aviary-landing

Comment 9

14 years ago
Because of this bug it seems that I cannot install my .xpi that has a .jar 
file and an xpcom component in any of the current windows firefox/mozilla 
downloads.

When are the downloads compiled again? Or is there something else to do?

Comment 10

14 years ago
I'm getting this, or something similar, when trying to install Firefox 1.0.1 on
Windows 2000.
http://derekdev.com/mozilla/error1.png
http://derekdev.com/mozilla/error2.png

Here's how the installer looks
http://derekdev.com/mozilla/error3.png

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.