Subject or Sender contains (searchbox) does nothing

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: mcsmurf, Assigned: Ere Maijala (slow))

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.09 KB, patch
neil@parkwaycc.co.uk
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
To reproduce:
1. Go to any mail/news folder/group
2. Enter something in Subject or Sender contains

Notice nothing happens, in JS Console only
Error: gSearchInput has no properties
Source File: chrome://messenger/content/searchBar.js
Line: 188

Happens with current cvs trunk build.
(Reporter)

Updated

14 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

14 years ago
Maybe the bugfix for Bug 203386 exposed this bug?

Comment 2

14 years ago
Yes, it looks like the viewDebug call was depending on FocusRingUpdate_Mail
calling GetSearchInput() and therefore indirectly setting gSearchInput.
(Assignee)

Updated

14 years ago
OS: Windows 2000 → All
(Assignee)

Updated

14 years ago
Assignee: sspitzer → emaijala
(Assignee)

Comment 3

14 years ago
Created attachment 168023 [details] [diff] [review]
Proposed patch

Let's initialize the search bar before trying to use it.
(Assignee)

Updated

14 years ago
Attachment #168023 - Flags: review?(neil.parkwaycc.co.uk)

Comment 4

14 years ago
Comment on attachment 168023 [details] [diff] [review]
Proposed patch

Looking at initializeSearchBar I don't think we should be calling it all the
time... particularly when the search bar is blank.
Attachment #168023 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 5

14 years ago
Created attachment 168026 [details] [diff] [review]
Patch v1.1

Ok, how about this approach?
Attachment #168023 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #168026 - Flags: review?(neil.parkwaycc.co.uk)

Comment 6

14 years ago
Comment on attachment 168026 [details] [diff] [review]
Patch v1.1

Assuming I'm looking at the same function, getDocumentElements doesn't seem to
set gSearchInput...
Attachment #168026 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 7

14 years ago
Comment on attachment 168026 [details] [diff] [review]
Patch v1.1

I'll try again :)

It does call GetSearchInput() which initializes gSearchInput. I could of course
just call GetSearchInput() as some others in that file seem to do. Would that
be somehow better?
Attachment #168026 - Flags: review- → review?(neil.parkwaycc.co.uk)

Comment 8

14 years ago
Comment on attachment 168026 [details] [diff] [review]
Patch v1.1

Sorry for the oversight, was looking at the wrong searchBar.js :-[ This looks
ok but I can't test it myself at the moment.

Comment 9

14 years ago
Comment on attachment 168026 [details] [diff] [review]
Patch v1.1

this works for me.
Attachment #168026 - Flags: superreview+

Comment 10

14 years ago
Comment on attachment 168026 [details] [diff] [review]
Patch v1.1

as david says it works...
Attachment #168026 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Comment 11

14 years ago
Fxi checked in to trunk.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Verified FIXED with both POP3 and IMAP accounts using build 2005-01-17-07 on
Windows XP Seamonkey trunk.
Status: RESOLVED → VERIFIED

Comment 13

13 years ago
*** Bug 277884 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 286367
You need to log in before you can comment on or make changes to this bug.