ENTER access in page key will not allow change of URL

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: lrutker, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The S5 slideshow latest beta (http://www.meyerweb.com/eric/tools/s5/testbed/)
seems to use the ENTER key as one of the access keys to move to the next slide.
It uses JavaScript for this
http://www.meyerweb.com/eric/tools/s5/testbed/v11b1/slides.js (see function
keys(key)). when the slideshow is loaded the ENTER accesskey prevents the enter
key from being used to load a new URL.
An interesting related bug is that the Go button also does not work. I assume
that the Go button just fires off a ENTER key event

Reproducible: Always
Steps to Reproduce:
1. load http://www.meyerweb.com/eric/tools/s5/testbed/
2. enter http://www.mozilla.org in the URL bar
3. Hit the ENTER key (or Go button)

Actual Results:  
Slide increments one slide

Expected Results:  
Mozilla home page loading

see http://www.meyerweb.com/eric/thoughts/2004/12/02/s5-11b1/#comments for more
discussion on the subject.
Extensions installed include Diggler 0.9,  Web Developer 0.9
Worksforme - enter in the addressbar isn't stolen by the content. You might want
to try disabling Web Developer (which, despite it's ubiquity, seems to be
involved in lots of these "things stolen" bugs), and if it then works, take it
up with the extension developer (and resolve this bug INVALID).

Updated

14 years ago
Assignee: aaronleventhal → events
Component: Keyboard Navigation → DOM: Events
Product: Firefox → Core
QA Contact: jruderman → ian
Version: unspecified → Trunk
Whatever the secret of reproducing this is, it doesn't seem to be either of
those extensions: I installed both in a new profile, same OS and Firefox as the
reporter, and still get the same non-result: enter in the URL bar does advance a
slide, but also goes to the typed address.
(Reporter)

Comment 3

14 years ago
After disabling all my extensions and enabling them 1 by 1 I tracked it down to
adblock. Can this somehow be transfered to that extension?
In any case I guess it is not a Firefox bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.