Closed Bug 27289 Opened 25 years ago Closed 23 years ago

Right clicking on any part of scrollbar shows context menu

Categories

(SeaMonkey :: Themes, defect, P3)

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.0

People

(Reporter: snickell, Assigned: bugzilla)

References

Details

Attachments

(2 files)

Right clicking on the scrollbar displays the last context menu.

Two simple examples:

Load mozilla, open a web page. Before using any context menus right click on the
scrollbar. It (presumably) lists every context menu the browser knows about.

Then try right clicking on a link. Now right click on the scrollbar to find that
the menu is the same as on the link (with options like "Open in New Window".

Should the scrollbar even *have* a context menu?
probably a job for don's team, to ensure that the target is not a scrollbar.
Assignee: pinkerton → don
*** Bug 27209 has been marked as a duplicate of this bug. ***
*** Bug 28046 has been marked as a duplicate of this bug. ***
*** Bug 28529 has been marked as a duplicate of this bug. ***
Reproduced on MacOS build 2000032308, MacOS 8.6. Platform & OS == All.
OS: Linux → All
Hardware: PC → All
*** Bug 34841 has been marked as a duplicate of this bug. ***
Problem still remains....
...and its fixed... =)

Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
still see this: 2000.05.09.08 commercial bits. reopening --do let me know if
this is not an issue with mozilla bits, tho'.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reassigning as per Don
Assignee: don → law
Status: REOPENED → NEW
Target Milestone: --- → M19
Move to M20 target milestone.
Target Milestone: M19 → M20
Oops.  Should be M21.
Target Milestone: M20 → M21
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
Status: NEW → ASSIGNED
*** Bug 45837 has been marked as a duplicate of this bug. ***
*** Bug 46441 has been marked as a duplicate of this bug. ***
Someone (I forget who, and can't find the bug right now) fixed this while 
fixing another bug.  The only remaining problem now is that right clicking on 
the scrollbar thumb will show a context menu.  This should be no harder then 
adding another check to see if the source is a thumb node, so when I get a 
chance, I'll take a look.
Summary: scrollbar context menu loads last context menu → Right clicking on scrollbar thumb shows context menu
reassigning to me to investigate
Assignee: law → BlakeR1234
Status: ASSIGNED → NEW
attached a patch - please review.
Status: NEW → ASSIGNED
Keywords: approval, patch, review
Target Milestone: M21 → M18
r=law

Nice work, Blake.

This broke after I originally fixed it because of some subtle change with 
respect to anonymous children of xbl widgets.  I heard Dave Hyatt talking about 
it but the bug never came to my attention (since it ain't [nsbeta3+]).  Thanks 
for backing me up on this one.
no problem. thanks for reviewing.  brendan, could you approve?
Keywords: review
a=brendan@mozilla.org.

Blake, did you ask a XUL guru (waterson might know) why tagName came back with
the namespace-prefixed "xul:slider"?

/be
Nope.  Waterson, do you have any idea why?
Partial answer/guess: this element is coming from the XBL anon content, where it
is declared with the xul: prefix inside the XBL document that defines the binding.
John: probably right.

fix checked in
Status: ASSIGNED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
Why is this marked fixed?
WHen i right-click on thumb i still get a context menu.
In addition i get error messages - heaps: One single right-click now spawns this:

Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:slider', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:slider', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:spring', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:thumb', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:slider', is this OK?
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:slider', is this OK?
forgot: m18 linux build ID 2000082608
I don't understand what's going on.  I checked in four patches yesterday and 
none of them seem to have taken any effect in today's build.  I am looking into 
it.
2000082708

discovered something:
The context menu that now displays when right-clicking scrollbar slider isn't
like it used to be: It used to be either one insanely long one (all possible
items) - or a copy of whatever context-menu had previously been displayed)

Now - instead - it's always one and the same, and it's identical to the one that
should display when one right-clicks somewhere in a normal web-page. (on
content-less area)

Also: RIght-clicking scrollbar thumbs (w/arrows) or on the sliderbar as such
(outside slider) has no effect.


So the behaviour has changed, compared to the original bug.
But that scrollbar slider for some reason thinks it's an extention of a webpage..
I hope someday that Mozilla can get Win2k's feature of a scrollbar specific
context menu when right-clicking a scroll area (not on the thumb). It's gonna be
hard to play keep-up with native widgets.
Sorry for the spam. Adding self to CC.
jerrybaker@weirdness.com: the feature you talk about is already filed as
enhancements bugs: bug 38466 and bug 38467 (both "future")
2000082916 m18 linux

Menu still there.. and..
clicking right mousebutton down on slider area spawns 7 lines like this:
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:slider', is this OK?

clicking right mousebutton down on scrollbar's arrow widgets spawn 7 of these:
Possible DOM Error: .name, .nodeName or .tagName requested on a namespace
element/attribute with the qulaified name 'xul:scrollbarbutton', is this OK?

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I don't know if this is related,
When I drag the scrollbar, then right-click, I get a pop-up menu,
and (this only happens somtimes) the menu stays active, I can release both
mousebuttons. My mouse now moves normally, I can use the context menu, and the
scrollbar still reacts as if I'm holding down the left button.

(build 2000080712)
2000090206 linux:
error messages gone. Menu remains.
Status: REOPENED → ASSIGNED
Priority: P3 → P2
Linux 2000-090708: no menu anymore?!
(is this too good to last..)
I don't know.  Let's take advantage of it and re-mark it FIXED while it still 
works!
Status: ASSIGNED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
It's back :/
I have a sneaking suspicion that this regression is due to bug 53537 (about 
event.target.localName returning "HTML")
Possibly. That other bug I have a fix for, and it is simply to use 
event.originalTarget when dealing with the scrollbar. Otherwise, you
get the parent document when dealing with anonymous content (or words
to that effect).
reopening because context menus are now shown when you right click on *any* 
part of the scrollbar (slider, arrows, and background).  what syntax changed?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Right clicking on scrollbar thumb shows context menu → Right clicking on any part of scrollbar shows context menu
Status: REOPENED → ASSIGNED
Priority: P2 → P3
Target Milestone: M18 → mozilla1.0
This still happens:
Right-clicking on the scrollbar pops-up the exact same context menu as when
clicking in the content part of the window.
Maybe this simply will be fixed when XBL events bubble last? (I heard that's
what's supposed to happen anyway). Approval and patch keywords should be
removed, imho.
I think pink is planning on preventing this at a higher level than xpapps 
(along with other stuff, like certain form controls).  cc'ing him
i just checked in a fix for this.
Assignee: blakeross → pinkerton
Status: ASSIGNED → NEW
.
Status: NEW → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
I still get a context menu on Windows.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ah, it's win32 classic. i guess they don't use the same scrollbar bindings as the 
others. --> skins.
Assignee: pinkerton → hewitt
Status: REOPENED → NEW
Component: XP Toolkit/Widgets: Menus → Themes
QA Contact: jrgm → pmac
hewitt, sr?
Assignee: hewitt → blakeross
yikes. sr=hewitt
r=kerz
Fix was checked in.
Status: NEW → RESOLVED
Closed: 24 years ago23 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Verified the patch.
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: