email address menu item in context menu of mailaddress image on header panel is not updated

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Teune van Steeg, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird1.1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I right click on the little buddy icon in the header panel a context menu
appears and the first menu item is empty. When I left click on that icon the
email address is displayed on that menu item. If I then right click on another
icon with a different email address attached to it, the email address belonging
to the previous icon is still displayed in that menu item. Left clicking fills
in the right email address.

When I click on 'add to addressbook' or 'copy email address' the right email
addresses are used, however.

The icon is not present in default theme: Qute, it is in winstripe theme, but
you can access it in Qute it is about 2px right after an email address.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
empty menu item or wrong email address in first context menu item, when right
clicking

Expected Results:  
Menu item should contain right email address
(Reporter)

Comment 1

13 years ago
This has been tested with thunderbird 0.9 and RC1.

/* Background info -> devs can skip this */

I personnally didn't know what to do with those icons when I used the winstripe
theme for the first time. So I hovered over them hoping for a tooltip. When no
tooltip appeared, I right clicked on them and I found a menu with an empty menu
item. But I still didn't know what to do with that icon, so I clicked on it kind
of expecting it would add the email address to my address book. But to my
surprise the same context menu appeared with the menu item filled this time. 

/* end of background info */

So, I think the icons should behave differently from what they do now:
1) Left clicking: add email address to address book. (brings up add address dialog)
2) Hovering: a tooltip text saying "Add this address to your address book"
3) Right clicking: the context menu which is currently displayed but with "add
to address book" bold (because it is the default action).
(Reporter)

Comment 2

13 years ago
Created attachment 168097 [details] [diff] [review]
removing of context attribute of the emailImage image so the contextmenu of the binding is shown

By removing the context attribute of the emailImage image in the
mail-emailaddress binding, the right element (the binding itself) is passed as
document.popupNode from which the fillEmailAddressPopup function the
emailaddress attribute reads. The label of the first menuitem in the popupmenu
is set to the value of this emailaddress attribute
(Reporter)

Updated

13 years ago
Attachment #168097 - Flags: review?(mscott)
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> So, I think the icons should behave differently from what they do now:
> 1) Left clicking: add email address to address book. (brings up add address
dialog)
> 2) Hovering: a tooltip text saying "Add this address to your address book"
> 3) Right clicking: the context menu which is currently displayed but with "add
> to address book" bold (because it is the default action).

The blue email addresses immediately left from the email image also has the same
popup and contextmenu (belonging to the mail-emailaddress binding containing
both the image and the label).
So I propose different behavour for these labels as well:
1) Left Clicking: Compose mail to the email address
2) hovering: a tooltip text saying "compose mail to <email address>"
3) Right clicking: the context menu which is currently displayed, but with
"Compose Mail To" bold (default action).
(Reporter)

Updated

13 years ago
Summary: email address menu item in context menu of buddy icon on header panel is not updated → email address menu item in context menu of mailaddress image on header panel is not updated
(Reporter)

Comment 4

13 years ago
I can still see this in the latest trunk build: version 1.0+ (20050331),
Just rightclick right (1-2 px) of a email address in the header pane, and no
email address is present in the upper contextmenu menuitem, when you didn't
rightclick an email address in the header pane previous.
(With default theme)
(Assignee)

Comment 5

13 years ago
I see this too but (using the default theme) I can't get the buddy icon to show
up in the envelope. gotta figure out why.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 6

13 years ago
Comment on attachment 168097 [details] [diff] [review]
removing of context attribute of the emailImage image so the contextmenu of the binding is shown

I've been running with this change for a while and its been working.
Attachment #168097 - Flags: superreview+
Attachment #168097 - Flags: review?(mscott)
Attachment #168097 - Flags: review+
Attachment #168097 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #168097 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
(Assignee)

Comment 7

13 years ago
thanks for the patch
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.