Closed Bug 272919 Opened 15 years ago Closed 15 years ago

resizing text should have "zoom" semantics

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64926

People

(Reporter: cconover, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I have a suggestion / request for the semantics of changing text size. 
Currently this feature updates the size but does not maintain your position in
the page.   As a result you lose your position when you resize.  It would be
much nicer to zoom into the page so that the text size changes but your position
does not.

For example, click on this link:
    http://www.mozilla.org/quality/bug-writing-guidelines.html
and search for the text:
    "How to Enter your Useful Bug Report into Bugzilla"
now increase the text size.  Notice that your position changes.

The correct behavior should be that your relative position stays the same.

For all its worth, the problem seems to be that the original position is
calculated as some sort of absolute pixel offset from the top, instead of the
percentage into the page.  The fix would seem to be to use a relative offset
(percentage).

Thanks!

Reproducible: Always
Steps to Reproduce:
1. click on this link:
    http://www.mozilla.org/quality/bug-writing-guidelines.html
2. search for the text:
    "How to Enter your Useful Bug Report into Bugzilla"
3. now increase the text size.  Notice that your position changes.

The correct behavior should be that your relative position stays the same.
Actual Results:  
The position within the page changed

Expected Results:  
It should maintain the same position within the page

Readily reproducible, should be easy to verify.

*** This bug has been marked as a duplicate of 64926 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.