Copy paste from Excel to TB with formatting

RESOLVED DUPLICATE of bug 195012

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 195012
13 years ago
13 years ago

People

(Reporter: Peter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Unknown; U; Unknown; rv:10.1) Gecko Firefox
Build Identifier: 

When selecting cells in Excel and copy/pasting to Thunderbird compose window
(HTML compose mode), the table is created but formatting such as borders,
background colors, etc. are not copied.

This is similar in behavior to 239817, "Paste tables from MS Word for Macintosh
into Thunderbird email message"

Reproducible: Always
Steps to Reproduce:
1. Select a range of formatted cells with data in Excel
2. Copy to clipboard
3. Paste in compose window of new HTML mail in TB

Actual Results:  
Simple table created with data in cells

Expected Results:  
Reproduction of cells with colors, borders, fonts, etc. as shown in Excel
(Outlook currently does this)

Comment 1

13 years ago
bug 221144 ?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)

Bug 221144 is different in that it's primarily concerned with the data not being
visible. TB shows the data in a simple table. It works, just has no formatting.
There's also bug 205830 which deals with the paste not working at all but TB
doesn't have that problem. So, it seems more of a feature request than a bug.

Honestly, I only did a search for Excel under the Thunderbird product since the
Mozilla product is the back end for TB and this feature might have to be
addressed in the front end when it's available in the back end. If that's not
the case, then I'm all for rolling this up with a corresponding Moz bug.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 195012 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.