If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message Filters UI needs to be redesigned

RESOLVED DUPLICATE of bug 253444

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 253444
13 years ago
13 years ago

People

(Reporter: Alexey Chernyak, Assigned: Scott MacGregor)

Tracking

unspecified
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
1.0RC1 (20041201) Win32

I find Message Filters UI in a shameful state.
Especially the Filter Rules window - you can't delete filter rules in the middle
without removing all of the rules that follow it. The "Fewer" button basically
creates a dataloss behaviour.

Steps to reproduce:

1. Create a filter with multiple rules.
2. Try to remove a rule in the middle of the Filter Rules list.

Current Behaviour: can't delete the rule without deleting all rules that follow it.

Expected Behaviour: a humanly usable interface instead of this archaic monstrocity.

Additionally see:
Bug 229484.
Bug 229494.
Bug 229487.
Bug 202729.

Apart from frontend design problems, filters backend has them as well, eg. bug
103658, and it does also needs to be redesigned eventually.

And finally what Thunderbird should've had but never got: Bug 263441.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0?
won't make the 1.0 train - minusing.  This type of redesign is too big to
consider for the 1.0 release.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 2

13 years ago
How did someone with so much attitude ever get the right to start bugs already 
confirmed?

What 'dataloss' exactly are we talking about?

> Current Behaviour: can't delete the rule without deleting all rules that
> follow it.

Oh, look -- a dupe.

*** This bug has been marked as a duplicate of 253444 ***
Severity: major → enhancement
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: dataloss
OS: Windows Server 2003 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.