edit->preferences and tools->extensions forget my selections and downloads

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: iwanttokeepanon, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041119 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041119 Firefox/1.0

If I go to tools->extensions and install 1 or more extensions and restart
firefox (which is what the installer says to do), the extensions are never
saved.  I searched chrome and extensions and looked at all the config files and
there is nothing new in them.  Only the default DOM inspector extension.

If I go to edit->preferences and set an option (e.g. proxy), click ok, and go
back to edit->preferences; the settings will be lost.  (see the 2 URLs for
before and after shots)

On the stdout I can see this:
   % firefox
   No running windows found
   *** loading the extensions datasource
   *** getItemProperty failing for lack of an item. This means
getResourceForItem                 failed to locate a resource for aItemID (item
ID =
http://ftp.mozilla.org/pub/mozilla.org/extensions/web_developer/web_developer-0.8-fx.xpi,
property = disabled)
   *** getItemProperty failing for lack of an item. This means
getResourceForItem                 failed to locate a resource for aItemID (item
ID =
http://ftp.mozilla.org/pub/mozilla.org/extensions/web_developer/web_developer-0.8-fx.xpi,
property = internalName)
   *** getItemProperty failing for lack of an item. This means
getResourceForItem                 failed to locate a resource for aItemID (item
ID = {c45c406e-ab73-11d8-be73-000a95be3b12}, property = internalName)


And I think I've seen similar results from edit->preferences before.  These 2
seem to be related.  I.e. they both either fail to parse a config file and
populate a dialog box.  Or they both fail to save the dialog entries back into
the config file.

Reproducible: Always
Steps to Reproduce:
1.  edit->preferences, general, connection settings, set a manual proxy
2.  click ok
3.  edit->preferences, general, connection settings, confirm manual proxy
settings lost or incomplete.  Port is *always* lost.

OR

1.  tools->extensions, install 1 extension
2.  restart firefox
3.  tools->extensions, verify that only DOM Inspector shows up

Actual Results:  
To use the edit->preference dialog, I have to fill in *all* of my preferences
since the dialog is not prepopulated.  I have to set my java(script), save
passwords, use SSH/TLS, proxy, etc... everytime or risk loosing them when I
click ok.

Extensions are effectively disabled.

Expected Results:  
saved preferences and installed extensions.

I use Gentoo:
   Linux ***.com 2.6.7 #9 Tue Sep 14 16:10:00 CDT 2004 i686 Pentium III
(Coppermine) GenuineIntel GNU/Linux

FireFox 1.0 (as compiled by the Gentoo emerge facility)

VTWM 5.4.6a (the virtual desktop version of TWM)

I will test with a different WM.
This sounds like your profile is either horked or the directory is read-only.

Does this happen with the Gentoo binary and the mozilla.org binary?
Summary: edit->preferences and tools->extensions forget my selections and downloads → edit->preferences and tools->extensions forget my selections and downloads
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> This sounds like your profile is either horked or the directory is read-only.
> 
> Does this happen with the Gentoo binary and the mozilla.org binary?

The gentoo binary.  I confirmed the same behaviour in KDE ( http://img.
photobucket.com/albums/v312/iWantToKeepAnon/firefox-after-KDE.jpg ).

The directory looks fine (rw for owner).  I confirmed the bug under my id and as 
root.  I will try the downloaded copy to see if it demonstrates this bug.
(Reporter)

Comment 3

14 years ago
> Does this happen with the Gentoo binary and the mozilla.org binary?

Oops, it does not happen in the mozilla.org binary.  Must be a compile flag
messing things up?

Here are my CLFAGS
  CFLAGS="-O3 -pipe -march=pentium3 -mfpmath=sse -msse -mmmx -ffast-math
    -fomit-frame-pointer -fforce-addr -falign-functions=4"

These are the same flags that linux, X11, XEmacs, etc... were compiled with. 
Maybe the frame-pointer, force-addr, align-functions are messing things up?

This report can be resolved, I will try different more conservative flags.  I
will also see if gentoo.org has heard of this.  If you want a report on a
conservative recompile, leave the bug open and I will resolve it on Monday when
I get back to this PC and the compile is complete.

Thx for the knock in the head, I should have tried that binary earlier.
(Reporter)

Comment 4

14 years ago
> > Does this happen with the Gentoo binary and the mozilla.org binary?
> 
> Oops, it does not happen in the mozilla.org binary.  Must be a compile flag
> messing things up?


Ok, I was getting the same bug(?) at home.  After recompiling w/just "-O -pipe";
I get FireFox w/o this symptom (i.e. edit->preferences works great!  will try
tools->extensions).

My home pc is a SMP w/ 2 intel processors and I installed gentoo (and all linux
kernels and apps) w/
   CFLAGS="-O3 -pipe -march=pentium2 -mmmx -ffast-math -mfpmath=387
      -fomit-frame-pointer -fforce-addr -falign-functions=4"

So I am guessing that one of the following is the culprit:
   -mmmx -ffast-math -fomit-frame-pointer -fforce-addr -falign-functions=4

(those are the only common flags btwn home and work)

Since that can be upto 5 recompiles to find the offender, is it worth it?  Let
me know.  If we can find the cause, it might be nice to add a warning to
'configure' to not use flag-x.  Any suggestions on which flag to nuke first?

Note: I like gentoo and how it "shrink wraps" libraries and apps to my hardware,
but running just 1 bare "-O" app is ok w/me (but the perfectionist in me wants
to know why).  This fixes other dialog odd behaviours like not being able to
pick my download directory.

I guess you can resolve this request if you want.
-ffast-math I remember causing problems... I don't know about the rest.

--enable-optimize=-Os -g -pipe -m32 -march=i386 -mtune=pentium4 is what Fedora's
RPM uses, and I've yet to see a single problem.  You could switch those to
pentium2 opts and be pretty good.

Marking INVALID.  Gentoo builds do weird things due to the wacky opts used, that
we don't support universally for one reason or another.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)

> Marking INVALID.  Gentoo builds do weird things due to the wacky opts used,
> that we don't support universally for one reason or another.

I realize you cant support compiled binaries since you have no input on *how*
people do their compilations.  But dont label this a "Gentoo" issue.  Had I
been compiling under Redhat, SuSE, etc.... I would have used the same flags and
seen the same problems.

Better to label it a custom compile w/ wacky opts.

BTW, I didnt expect such fast responses.  Thx for great support.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.