languagesonline.org.uk - utf-8 pages do not display foreign accents - just query marks

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
14 years ago
4 years ago

People

(Reporter: ve3ll, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041203
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041203

the given url shows how accents are not displayed.
the page called accents really emphasises this as
pages delivered in 8859-1 display ok on firebird
but not mozilla.  opera has no problems with anything
on this site... 
if it is incorrect coding --let me know the issue
and i will relay to site owner

Reproducible: Always
Steps to Reproduce:
1. view homepage
2. select accents -- french
3. repeat with firefox and opera
4. watch page info for delivered encoding !!! 

Actual Results:  
query marks instead of acents

Expected Results:  
accents instead of query marks

Comment 1

14 years ago
Hello 

That ist not a problem of Mozilla/Firefox. You are sending an incorrect
http-header information.

Test your page in: http://web-sniffer.net/

You send: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7[CRLF]

See: http://www.w3.org/International/questions/qa-headers-charset

Delete utf-8 and it works.

Best regards 
Wolfgang
The page claims to be UTF8 in the headers, but the data is not actually UTF-8
(it's ISO-8859-1, looks like).  To evang to fix the server to not claim that the
data is UTf-8 when it's not.
Assignee: general → english-other
Status: UNCONFIRMED → NEW
Component: General → English Other
Ever confirmed: true
OS: Windows 98 → All
Product: Mozilla Application Suite → Tech Evangelism
QA Contact: general → english-other
Hardware: PC → All
Summary: utf-8 pages do not display foreign accents - just query marks → languagesonline.org.uk - utf-8 pages do not display foreign accents - just query marks
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.