Background update applied incorrectly to anchor image

VERIFIED DUPLICATE of bug 202942

Status

()

VERIFIED DUPLICATE of bug 202942
14 years ago
14 years ago

People

(Reporter: kittya, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999

If an anchor block contains an semi-transpearent image (instead of (or in
addition to?) text), and the background of the anchor block is changed by a
hover style, the region that is has its background changed is not the region of
the image, as it should be.

Reproducible: Always
Steps to Reproduce:
1. Create a web page with the following content

<style> a:hover { background: pink; } </style>
<a href="http://BreyFamily.net"><img
src="http://BreyFamily.net/images/HomeLink.gif"></a>

2. View the page with FireFox.
Actual Results:  
A pink rectangle about half the height of and a bit wider than the image appears.

Expected Results:  
The background of the image should become pink.
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk

Comment 1

14 years ago
Created attachment 167822 [details]
testcase

Comment 2

14 years ago
Mozilla's behavior here is correct.  see bug 202942

*** This bug has been marked as a duplicate of 202942 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.