Closed Bug 273091 Opened 15 years ago Closed 15 years ago

CSS stylesheet linked using @import does not get saved with "Save Page As..." (Web page, complete)

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: vr, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Go to, say http://alistapart.com/ and use "Save Page As..." (Web page, complete)
to save the page. The formatting is gone when the saved copy is viewed.


Reproducible: Always
Steps to Reproduce:
1. Visit http://alistapart.com/
2. Use "Save Page As..." menu, select (Web page, complete) to save the webpage


Actual Results:  
alistapart.com uses
<style type="text/css" media="screen">@import "/c/ala.css";</style>
to link the stylesheet. File "/c/ala.css" does not get saved.


Expected Results:  
File "A List Apart_files/c/ala.css" should have been saved and html source file
should have been modified to use a relative link in @import.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.