There is no way to disable locales

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: glandium, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.5) Gecko/20041201 Firefox/1.0 (Debian package 1.0-4pre5.0)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.5) Gecko/20041201 Firefox/1.0 (Debian package 1.0-4pre5.0)

There is no way to disable locales.

The first issue is that the EM only deals with package chrome stuff when it
disables an extension. (see nsExtensionEnabler.onRegisterChrome)

The second issue is that there is no mechanism in the ChromeRegistry to do the
equivalent of a setAllowOverlaysForPackage for locale and skin.

The third issue is that ChromeRegistry.SetLocale and SetSkin don't look if the
given locale or skin is disabled or not.

Note that all this is probably the cause of bug #260018.

Reproducible: Always
Steps to Reproduce:
1. Install a localization extension
2. Disable it through the Extensions Manager
3. Run firefox -UILocale this-locale

Actual Results:  
The locale is used.

Expected Results:  
The locale should not be used
(Reporter)

Comment 1

14 years ago
Changing product and component to those proposed by Daniel Brooks on IRC.
Component: General → Internationalization
Product: Firefox → Core
Version: unspecified → Trunk

Updated

14 years ago
Assignee: firefox → smontagu
QA Contact: firefox.general → amyy
(Assignee)

Updated

14 years ago
Assignee: smontagu → bsmedberg
Status: UNCONFIRMED → NEW
Component: Internationalization → XRE Startup
Ever confirmed: true
Product: Core → Toolkit
Version: Trunk → unspecified
(Assignee)

Comment 2

13 years ago
Whatever the problems were, they are fixed with new EM and chromereg changes.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: amyy → startup
You need to log in before you can comment on or make changes to this bug.