Have default settings for address box & buttons more closely match what common users expect

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
14 years ago
14 years ago

People

(Reporter: ilv2004, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1  and Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

When IE users come to Firefox or regular Mozilla they find the address bar 
(box) is not where they expect. Most users won't know how to change the layout -
 most would not know that you can even change the layout. This results in 
people trying Mozilla then going back to the evil IE. I suggest making 
the "default" layout look more like IE and more like the images I've attached 
to this report - to enhance Mozilla's market share.

Reproducible: Always
Steps to Reproduce:
1. Be a regular dumb user.
2. Use IE for a long time.
3. Try Firefox or regular Mozilla.
4. Notice how the buttons & address box/bar is not where your eyes or brain 
expects.
5. Dumb Mozilla & go back to IE.
6. We've lost a user.

As a more advanced user it took me a while to figure out how to change the 
layout & to even bother. Most users won't bother. So why not have a layout 
which is more close to what people are used to.

Actual Results:  
Most users: Trying Mozilla & going back to IE.
Advanced users: trying Mozilla & going back to IE for a while until they figure 
out or bother to change the layout settings in Mozilla.

Expected Results:  
Most users: going back to IE unless format is changed.
Advanced users: going back to IE for a while until they figure out or take the 
time to change the layout in Mozilla.
(Reporter)

Comment 1

14 years ago
Created attachment 167859 [details]
How the layouts in regular Mozilla & Firefox look by default - this is bad

How the layouts in regular Mozilla & Firefox look by default - this is bad
(Reporter)

Comment 2

14 years ago
Created attachment 167860 [details]
How the evil IE looks - which is what most users comming to mozilla will be expecting to see

How the evil IE looks - which is what most users comming to mozilla will be
expecting to see
(Reporter)

Comment 3

14 years ago
Created attachment 167861 [details]
Example of how I modified Firefox's layout. Please make this the default in Firefox & regular Mozilla.

Example of how I modified Firefox's layout. Please make this the default in
Firefox & regular Mozilla.
(Reporter)

Updated

14 years ago
Summary: Move address bar & buttons a bit so that they more closely resemble what common Joe & Jane expects → Have default settings for address box & buttons more closely match what common users expect

*** This bug has been marked as a duplicate of 273140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Blocks: 273140
(Reporter)

Comment 5

14 years ago
*** Bug 273140 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

14 years ago
*** Bug 273140 has been marked as a duplicate of this bug. ***
No matter how many screenshots you post, this is still WONTFIX. The interfaces
aren't different enough to worry about slight changes such as these. No one is
going to be "confused" because the address bar is a few pixels over.

See bug 273140 comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

14 years ago
This is the proper bug report to look at since it's the one with attachments.

Also with regard to the comment by another that most users who come to Mozilla 
aren't long time users of IE, that is a rather unhelpful comment. If you don't 
care about attracting previous IE users or keeping them, then how about 
removing the help for IE users in Mozilla.

I used Netscape first when the web was first starting. Then IE for a long time 
because Netscape was so buggy and Netscape/AOL could have cared less. Now I'm 
trying Mozilla again. 

Perhaps a skin would be useful. There is an IE skin, but it doesn't move the 
address box.
(Reporter)

Comment 9

14 years ago
Gavin Sharp wrote: "No matter how many screenshots you post, this is still 
WONTFIX. The interfaces aren't different enough to worry about slight changes 
such as these. No one is going to be "confused" because the address bar is a 
few pixels over."

I was Mr. Sharp. I don't care if you don't care. If you are the face of Mozilla 
perhaps I'll go back to IE.

The default IE UI is suboptimal, from a usability perspective, and changing
Firefox to match would be considered a regression by most people.  Our focus and
our success has been with providing a better user experience than other
browsers, not in duplicating their UI.
You need to log in before you can comment on or make changes to this bug.