Mac: HTML Selects no longer support "click-and-hold" gesture

VERIFIED FIXED in Future

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Eli Goldberg, Assigned: waqar)

Tracking

({pp})

Trunk
Future
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
build id: 2000021008 (Mac only, can't reproduce on Windows)

Steps to reproduce:
	- Click & hold the mouse button on a Bugzilla menu (e.g. Platform or 
severity)
	- While holding the mouse button down, drag across the menu items

...observe that the selected menu item isn't changing --- it sticks to the 
initially selected item.

Current behavior:

	Select menus within a form on Mac are not supporting the traditional Mac 
menu selection gesture of clicking and holding on the menu, with selection made 
by releasing the mouse button.

Expected behavior:

Currently, we're only supporting the Windows (and Mac OS 8+) gesture of clicking 
on the menu, selecting the desired menu item, and then clicking again to select 
it.
(Reporter)

Updated

18 years ago
Keywords: pp

Comment 1

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods

Comment 2

18 years ago
hyatt this is yours or saari's
Assignee: rods → hyatt

Comment 3

18 years ago
No, he's talking about combo boxes.
Assignee: hyatt → rods

Comment 4

18 years ago
Changing title to make the bug less confusing.
Summary: Mac: Select menus no longer support "click-and-hold" gesture → Mac: HTML Selects no longer support "click-and-hold" gesture

Comment 5

18 years ago
elig, you can click and hold on Win32 too.  Have you tested that to see if it is 
also broken?
(Reporter)

Comment 6

18 years ago
Yup. Sorry, by "can't reproduce on Windows", I meant that the "click and hold" 
behavior works correctly on HTML Selects using Win32.

Comment 7

18 years ago
waqar, could you take a look at this, it seems like a regression to me.
Assignee: rods → waqar
(Assignee)

Comment 8

18 years ago
As per Gecko meeting today, mass move to M15
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 9

18 years ago
This works fine for me on OS9 with 2000032110 build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

18 years ago
QA Assigning to self for verification.
QA Contact: ckritzer → elig
(Reporter)

Comment 11

18 years ago
Re-opened using 3.27 AM build on Mac OS; still occurs.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 12

18 years ago
Might the regression in 33421 ([REGRESSION]<optgroup> in <select> breaks 
scrolling drop down lists) be related to this bug?
(Assignee)

Comment 13

18 years ago
Moving
Status: REOPENED → ASSIGNED
Target Milestone: M15 → M17
(Assignee)

Comment 14

18 years ago
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
(Assignee)

Comment 15

18 years ago
Forgot to set the milestone.
Target Milestone: M17 → Future

Comment 16

17 years ago
Fixed? This now works as expected. Test it out - change the OS back to Mac
System 8.5 using this method (I changed it to 9.0 using this method).
OS: Mac System 8.5 → Mac System 9.0

Updated

17 years ago
OS: All
QA Contact: elig → bsharma
(Assignee)

Comment 17

17 years ago
It works with 01/24/2001 build.
(Assignee)

Comment 18

17 years ago
Forgot to close
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
*Sorry for the SPAM*
Mid Air collision / bugzilla cleanup
Current bug state Resolved and NO Resolution.
Status: RESOLVED → REOPENED
marking resolved / fixed
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
verifried build 2001081308 os:mac8.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.