Can't change location using enter key in SVG

RESOLVED DUPLICATE of bug 273197

Status

()

Core
SVG
--
major
RESOLVED DUPLICATE of bug 273197
13 years ago
13 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041103 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041103 Firefox/0.9.1+

SVG links don't enter the tab order, so it isn't possible to select one and
change location using the 'enter' or new line key

Reproducible: Always
Steps to Reproduce:
1. Load testcase.
2. Press tab four times.
3. press enter

Actual Results:  
Focus moves between the content area and the text field(s) in the chrome.


Expected Results:  
Focus should move once to each of the two links on that page.
Location should change when the enter key is pressed

this bug is part of a larger series of bugs related to Device Independence:
https://bugzilla.mozilla.org/show_bug.cgi?id=273099
The bug here isn't that you can't press enter, it's that you can't focus the
link. Which I already filed as bug 273197. There's no way to check if enter
doesn't trigger the link, since there's no way to send it an enter key event
from the UI in the first place.

*** This bug has been marked as a duplicate of 273197 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.