When closing last tab, the "tab bar" disappear instead of closing mozilla (using the close button on the "tab bar").

RESOLVED DUPLICATE of bug 154335

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 154335
14 years ago
5 years ago

People

(Reporter: François Gagné, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122

The title pretty much said it all: When closing last tab, the "tab bar"
disappear instead of closing mozilla (using the close button on the "tab bar").

Reproducible: Always
Steps to Reproduce:
1. Uncheck the "Hide tab bar when only one tab is open"
2. Open a web page
3. Close the first and only tab with the close button on the tab bar.
Actual Results:  
The tab bar disappear.

Expected Results:  
Mozilla navigator should close. The reason behind this is the principe "of less
suprise", the behaviour of the close button on the "tab bar" shouldn't change
depending on the number of tabs.

Comment 1

14 years ago
The browser should be closed when the last tab is closed, instead of making it
blank.  I'm hoping FF 1.1 will have this feature.

Comment 2

14 years ago
FF shows this only with Ctrl+W, if you use the [x] the last tab changes to
about:blank. See Bug 248987 and Bug 236721. I don't think your behavior will be
accepted, see bug 156082.
Not a core tabbrowser issue in any case.  This is probably wontfix for
SeaMonkey, no idea for Firefox, and likely a duplicate...
Whiteboard: DUPEME

Comment 4

14 years ago
see also bug 154849 

*** This bug has been marked as a duplicate of 154335 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.