Simple Mapi call corrupts email To: Address

RESOLVED DUPLICATE of bug 221673

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 221673
14 years ago
14 years ago

People

(Reporter: Peter Batten, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

39.50 KB, application/msword
Details
39.50 KB, application/msword
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

When calling Mozilla Mail from another program using Simple Mapi the Addressee
appears correctly in the To: box but the To: Address is incorrectly modified
when sent.  eg Test@hotmail.com becomes STest@hotmail.com

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Test@hotmail.com becomes STest@hotmail.com

Expected Results:  
Test@hotmail.com should be Test@hotmail.com

Screen shots available if desired.

Comment 1

14 years ago
Is this problem seen with Mozilla MailNews (the suite) or with Thunderbird?

I do not see this symptom at all with either program.  What program is making 
this call?  Do you see the same symptom entering a mailto: URL into Windows'
   Start | Run?
(Reporter)

Comment 2

14 years ago
Created attachment 174262 [details]
Mapi Screen Shot
(Reporter)

Comment 3

14 years ago
Created attachment 174263 [details]
Mapi Mail Error
(Reporter)

Comment 4

14 years ago
(In reply to comment #1)
> Is this problem seen with Mozilla MailNews (the suite) or with Thunderbird?
> 
> I do not see this symptom at all with either program.  What program is making 
> this call?  Do you see the same symptom entering a mailto: URL into Windows'
>    Start | Run?

In Case you did not receive my direct response.

Dear ????

Thanks for the reply.

I believe that I am using Mozilla MailNews. Help about just says Mozilla
1.7.3.

I am using a CRM system called Up Close and Personal.  You can download this
from www.ucap.biz - it is free.

UCAP can call any MAPI object to use it as an eMail engine. When calling
Mozilla Mail it correctly displays the eMail address on screen (see
attachment Mozilla Mail Error.doc).  If the Send button is pressed the
Mozilla Mial Inbox screen pops with an error dialog showing the eMail
address has had an S prepended to it ie <Sdatafast@tpgi.com.au> ...User
Unknown. (see attachment Mozilla Mail Error Dialog.doc)

This appears to be an internal Mozilla in the transport from a Mapi call as
it does not occur with any Microsoft Mail systems ie Outlook or Outlook
express.

Regards

Peter


Comment 5

14 years ago
Is there supposed to be a difference between those two attachments?

In the future, please don't use Microsoft word to create screenshots.  Use an 
image file -- preferably PNG or JPG.

I don't see the "S" prepended to the address; I do see "SMTP:" prepended to the 
address, which is in fact a known problem.  Duping.

*** This bug has been marked as a duplicate of 221673 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.