Able to create events when a calendar does not exist

RESOLVED DUPLICATE of bug 183396

Status

RESOLVED DUPLICATE of bug 183396
14 years ago
13 years ago

People

(Reporter: daniel.oconnor, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

With no active calendars, a doubleclick can bring up the relevant add event
dialog. This should not be possible, as a user enters information but loses it
when the "OK" button is pushed.

Reproducible: Always
Steps to Reproduce:
1. Delete all calandars
2. Doubleclick to create a new event
3. Enter Data
4. Save

Actual Results:  
No event is created, as no calendar exists

Expected Results:  
The user should be prevented from going this far, or created a temporary calendar.

Comment 1

14 years ago
This sounds like the discussion taking place at the end of bug 183396. 
Preventing a user from deleting the main calendar, as that bug suggests, would
obviously make this bug go away.  Reporter, do you think this qualifies as a
duplicate of bug 183396?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> This sounds like the discussion taking place at the end of bug 183396. 
> Preventing a user from deleting the main calendar, as that bug suggests, would
> obviously make this bug go away.  Reporter, do you think this qualifies as a
> duplicate of bug 183396?

Highly similar issue, so it can't hurt to link them. If this is incorrect, its
easy enough to undupe.

*** This bug has been marked as a duplicate of 183396 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.