If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copy & Paste does not respect transparency of GIF-images

RESOLVED DUPLICATE of bug 249032

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 249032
13 years ago
10 years ago

People

(Reporter: Gregor Rosenauer, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Copy&Pase of images does not work for GIF-images that use transparency (GIF87a).

When copying the image of the given URL to the clipboard (rightclick-menu->"Copy
Image") and pasting it anywhere, you always get a black background (the image at
the given URL is totally black as also the drawing itself is black).

I do not know the specifics of the Windows clipboard and how it handles images,
but if transparency is a problem, at least a white background should be used,
sothat the image appears as in the browser.

The image is taken from:
http://edocs.bea.com/manager/mgr20/intref/overview.htm

I tried this with 2 GIF-images and got the same result (black background).
PNG transparency seems to work.

InternetExplorer produces the expected result (even;-).

Comment 1

13 years ago
*** Bug 264154 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
This might be related to 201198....but I can't recreate the bug.....

Comment 3

13 years ago
bug 249032?

Comment 4

12 years ago
This bug still exists in the latest Firefox build. It's annoying, as IE does
this correctly.
*** Bug 333327 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 335202 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
Duping to bug 249032 which is in the correct component
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 249032
You need to log in before you can comment on or make changes to this bug.