If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Compile fails with ActivePerl installed

RESOLVED DUPLICATE of bug 232003

Status

()

Firefox
Build Config
--
blocker
RESOLVED DUPLICATE of bug 232003
13 years ago
11 years ago

People

(Reporter: RyanVM, Assigned: Brian Ryner (not reading))

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041130 Firefox/1.0 (Community Edition FireFox P3W)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041130 Firefox/1.0 (Community Edition FireFox P3W)

When I try to make an installer build, the "make installer" command fails with
the following error:
--------------------------------------------
could not open
/cygdrive/c/mozilla/mozilla/browser/installer/windows/instgen/installer.cfg: No
such file or directory
make[1]: *** [installer] Error 2
make[1]: Leaving directory `/cygdrive/c/mozilla/mozilla/browser/installer/windows'
make: *** [installer] Error 2
--------------------------------------------
It turns out that the cause for this is ActivePerl 5.8.4 being installed. If I
remove C:\Perl\bin (ActivePerl's install directory) from PATH and use cygwin's
Perl instead, the installer builds fine.

This thread in Mozillazine also discusses the issue.
http://forums.mozillazine.org/viewtopic.php?t=177779

Reproducible: Always
Steps to Reproduce:
1. Install ActivePerl 5.8.4
2. Attempt to make installer
Actual Results:  
Make fails

Expected Results:  
Make succeeds

Updated

13 years ago
Assignee: bugs → bryner
Component: Installer → Build Config
QA Contact: bugzilla → asa

Comment 1

13 years ago
Confirming. This is a smoketest blocker, since we aren't even able to build the
installer here.
Severity: major → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: smoketest
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
(Reporter)

Comment 2

13 years ago
I updated the ActivePerl build to 5.6.811 and still the same problem.

timeless pointed me to using make 3.79 to get around the error I gave above,
however, I'm still getting other problems.  The only way to do a successful
build is with no form of ActivePerl installed.
Summary: Installer build fails with ActivePerl installed → Compile fails with ActivePerl installed

Comment 3

13 years ago
With bug #232003 fixed, does that fix this bug as well?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> With bug #232003 fixed, does that fix this bug as well?

Indeed it does :). I just made an installer using ActivePerl!

Comment 5

13 years ago
As per info in Comment #4, am dupping to Bug #232003

*** This bug has been marked as a duplicate of 232003 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.