bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

performance problem in javascript scroll

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: Daniel Mota Leite, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

going to the http://www.chip7.pt one sees that every time the top text scroll
the CPU reach the top (PIII-600)
openning several pages from this site will take all the CPU and slowing down
alot the firefox
in windows things seens alot better, both firefox and IE seens to use only
little CPU

and its the firefox that its using the CPU, not X11, unlike a similar problem in
konqueror (it updates too many times per second and makes X11 eats all the CPU,
konqueror uses only about 15% of the CPU)

dont know if this is a dupe, there are many performance bugs in bugzilla, but i
have no idea if any of then applies here

Reproducible: Always
Steps to Reproduce:
just go to the page, watch the CPU usage going up sharp when the text start to
scroll


Expected Results:  
i dont belive that this CPU dont have enough power for this script, in windows
things use little cpu, so there is a problem between firefox and linux. So the
CPU usage should be alot lower

Comment 1

14 years ago
>>going to the http://www.chip7.pt one sees that every time the top text scroll<<

On this site my top go from cpu 50% to 94% when javascript text shift.

Javascript scroll have the similar beaviour in other sites.

( Suse 9.2 - cpu via c3 800 Mhz )
Summary: performance problem in javascript scroll → performance problem in javascript scroll

Comment 2

13 years ago
I can confirm this problem. I closed the browser window and the firefox usage
went down to >1% while typing this bugzilla report. 

I've been looking for performance issues since I went to tvtome.com, which now
is tv.com, that site sucks all the CPU you have immediately.  

I installed the adblock plugin and blocked a whole pile of elements on the
tv.com site, I was not able to restore performance while javascript was enabled.

This seems to be an issue with firefox.  I am using Mozilla/5.0 (Windows; U;
Win98; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4.

Test case is tv.com and cnet.com which seems to exhibit this performance. 

This all on a slower laptop, 366 mhz windows 98. I haven't experienced such
performance problems with this machine, it's slow but useable however not on the
tv.com site. I could test more. 
Assignee: bross2 → nobody
The site in question no longer has the javascript scroll widget. If you find other sites with this issue using Firefox 2.0.0.3 or later, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.