create a new import of libical

RESOLVED FIXED in Sunbird 0.3

Status

Calendar
Internal Components
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Assigned: John Gray)

Tracking

unspecified
Sunbird 0.3

Details

Upgrading the current copy of libical is no real fun, because of the local patches.
We could just create a new import somewhere in /mozilla/calendar. libical is mpl
now, so it doesn't need to be in other-licenses anymore.

We can then apply needed local patches to the new copy.
Target Milestone: --- → Sunbird 0.3
Blocks: 237302
(Reporter)

Comment 1

13 years ago
Import is done, but not enabled yet. see mozilla/calendar/libical.
Since mozilla/calendar/libical was added I am unable to build calendar on OS/2. 
I get:
-MD,.deps/icaldirset.pp E:/cvs/work/mozilla/other-licenses/libical/src/libicalss
/icaldirset.c
E:/cvs/work/mozilla/other-licenses/libical/src/libicalss/icaldirset.c:511: confl
icting types for `icaldirset_add_component'
E:/cvs/work/mozilla/other-licenses/libical/src/libicalss/icaldirset.h:55: previo
us declaration of `icaldirset_add_component'
E:/cvs/work/mozilla/other-licenses/libical/src/libicalss/icaldirset.c:605: confl
icting types for `icaldirset_remove_component'
E:/cvs/work/mozilla/other-licenses/libical/src/libicalss/icaldirset.h:56: previo
us declaration of `icaldirset_remove_component'
make.exe[5]: *** [icaldirset.o] Error 1
make.exe[5]: Leaving directory `E:/cvs/work/mozilla/obj/other-licenses/libical/s
rc/libicalss'

There have been no changes to the other-licenses version since around May as I
can tell. My guess is this is related but if it isn't enable yet I don't know why.

Andy 
Thanks, that patch did fix it.
Andy

Comment 5

13 years ago
*** Bug 263515 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
This bug is fixed, I believe.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
is the other-licenses version still there?  if so, should it be?

Updated

12 years ago
QA Contact: gurganbl → libical
Component: libical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: libical → base
You need to log in before you can comment on or make changes to this bug.