Scrolling screws up the pointer's offset

RESOLVED DUPLICATE of bug 271702

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 271702
13 years ago
13 years ago

People

(Reporter: David Stone, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041206 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041206 Firefox/1.0+

I noticed this when I was using AiO today...but I've confirmed it on a build
w/out AiO installed as the same problem happens with the scrollwheel image. If
I'm at the top of a page and I draw a gesture (or click my scrollwheel, which
brings up that little circular scroll image), it's drawn right under my mouse
pointer. If I scroll down the page, the image (either the AiO gesture drawing or
the middle click scroll image) is offset from the pointer location by the amount
I scrolled down the page. So if I scroll down a little bit (say a few inches),
it's offset by a little bit. If I scroll all the way down, it's just gone. The
image is invisible. 

Reproducible: Always
Steps to Reproduce:
1. Middle click the scroll wheel, the image pops up under the mouse pointer.
2. Scroll down the page a bit.
3. Middle click the wheel again. The image should be below the mouse pointer
about the same amount as you scrolled down the page.
4. Lather, rinse, repeat. It happens every time.

Actual Results:  
Things that are supposed to be drawn under the mouse pointer get shifted further
below the pointer.

Expected Results:  
The images should be drawn directly under the pointer.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 271702 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.