OS choice in extension list gets reverted to "windows" when "next" is pressed

RESOLVED DUPLICATE of bug 269343

Status

RESOLVED DUPLICATE of bug 269343
14 years ago
3 years ago

People

(Reporter: gstaniak, Assigned: wolf)

Tracking

unspecified
x86
Linux

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.5) Gecko/20041108 Firefox/1.0

When browsing the extension list, if I choose "Linux" as the OS in the second
drop-down at the top of the page and then click "Next", the choice of OS gets
reverted to "Windows". Also, when I choose OS "Linux" in one of the subsections
of the list and click "Update", I get redirected to the "All" section instead of
staying in the chosen section.

Reproducible: Always
Steps to Reproduce:
1. Go to https://update.mozilla.org/extensions/?application=firefox
2. Click "All" in the side menu
3. Choose OS: "Linux" at the top of the page, click "Update"
4. Click "Next" in the navigation bar above the form - the choice of OS gets
reverted to "Windows"

Actual Results:  
The OS field displayed "Windows" again on the next page. The extension counter
changed, too (total number of extensions changed).

Expected Results:  
The OS field should show "Linux", and the extension counter should stay the same.
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 269343 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.