firefox windows installer writes invalid registry entries

RESOLVED WORKSFORME

Status

()

Firefox
Installer
--
minor
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: evilzenscientist, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The Windows Installer writes two invalid entries to the Windows Registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla
Firefox (1.0) | NoModify
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla
Firefox (1.0) | NoRepair

The install creates these as DWORD values with just 0x00 in the value; to be
truly valid they need a full DWORD.

"NoModify"=dword:00000000
"NoRepair"=dword:00000000

This is a cosmetic issue - but causes problems with repackaging software.

Reproducible: Always
Steps to Reproduce:
Install Firefox 1.0 on Windows XP
Actual Results:  
Bad registry values are created. The Product functions perfectly.

Expected Results:  
The expected behaviour is for the install to write correct DWORD values.
(Reporter)

Comment 1

13 years ago
Created attachment 168139 [details]
Windows Firefox 1.0 registry fixes
(Reporter)

Comment 2

13 years ago
The attachment is snafued - so here's the cut and paste of a working registry:

<snip>
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla
Firefox (1.0)]
"NoModify"=dword:00000000
"NoRepair"=dword:00000000
</snip>

Updated

13 years ago
Attachment #168139 - Attachment mime type: text/plain → text/plain;charset=UTF-16LE

Comment 3

13 years ago
The "Size" profile string has to be set for REG_BINARY and REG_DWORD values in
the installer's config.it or dwSize will be set to 0 and later passed to
RegSetValueEx creating invalid registry entries.

References:
http://lxr.mozilla.org/mozilla/source/browser/installer/windows/config.it#1017
http://lxr.mozilla.org/mozilla/source/toolkit/mozapps/installer/windows/wizard/setup/ifuncns.c#2126
http://lxr.mozilla.org/mozilla/source/toolkit/mozapps/installer/windows/wizard/setup/ifuncns.c#1904

Alternatively set dwSize fixed to 4 for DWORD values.

Sorry, no patch as I don't have a CVS set up.

Comment 4

13 years ago
Created attachment 177959 [details] [diff] [review]
config.it fixes

here's the simple patch, untested
I assume you checked this isn't a dupe.
setting ->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Michael, are you still interestd in fixing this? If so, you should ask for review from mconnor@mozilla.com by setting the appropriate flag on the attachment.

Comment 7

12 years ago
Comment on attachment 177959 [details] [diff] [review]
config.it fixes

OK, the patch is now outdated and I can't update it till later today. Should be pretty straightforward though. Just set the Size profile string to 4 bytes.
Attachment #177959 - Flags: review?(mconnor)
Comment on attachment 177959 [details] [diff] [review]
config.it fixes

please request review on the new patch when its ready
Attachment #177959 - Flags: review?(mconnor)

Updated

12 years ago
Attachment #177959 - Attachment is obsolete: true

Comment 9

12 years ago
Created attachment 201776 [details] [diff] [review]
config.it fixes v2

updated bandaid patch, real fix in 314904
Attachment #201776 - Flags: review?(mconnor)
This is fixed with the new installer that landed - bug 326580.
resolving -> wfm
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 11

11 years ago
Comment on attachment 201776 [details] [diff] [review]
config.it fixes v2

This file does not even exist anymore.
Attachment #201776 - Attachment is obsolete: true
Attachment #201776 - Flags: review?(mconnor)
You need to log in before you can comment on or make changes to this bug.