DeCOMtaminate nsIFontMetrics

RESOLVED DUPLICATE of bug 230605

Status

RESOLVED DUPLICATE of bug 230605
14 years ago
10 years ago

People

(Reporter: kherron+mozilla, Assigned: kherron+mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
nsIFontMetrics.h
<http://lxr.mozilla.org/seamonkey/source/gfx/public/nsIFontMetrics.h> defines a
number of getters of the form

    NS_IMETHOD  GetSomeValue(nscoord &aValue)

Generally, the implementations can't fail and are all hardcoded to return NS_OK.
The class seems a good candidate for refactoring.
(Assignee)

Comment 1

14 years ago
Created attachment 168140 [details] [diff] [review]
Proposed 1st-round changes

This is a proposal for a first round of interface changes. I'd appreciate some
feedback before developing the full patch.
(Assignee)

Comment 2

14 years ago
Arg. I searched for dupes. Really, I did.

*** This bug has been marked as a duplicate of 230605 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.