Mozilla places both the From and Reply-To addresses in To fields when the reply should only have been addressed to the Reply-To address

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Edward, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

When replying to an e-mail whose original headers include an address with the
Reply-To header, Mozilla correctly places this address in a To field, but also
places the original From address in another To field.  Reply-To should override
the From address on a reply, but Mozilla is not overriding it.


Reproducible: Always
Steps to Reproduce:
1.Open e-mail with header showing an address in the "Reply-To" field
2.Compose reply
3.Mozilla places both the "Reply-To" address and the "From" address in "To"
fields inside the Compose window.

Actual Results:  
The e-mail reply showed two address, both the original "From" address and the
"Reply-To" address.

Expected Results:  
Only the "Reply-To" address should have been placed in a "To" field.

Comment 1

14 years ago
I cannot reproduce this problem with Mozilla 1.8a6-1217, Win2K, nor with 
Thunderbird 1.0.

Reporter (edwardp7) -- if you also are not seeing this symptom with current 
builds, please mark this bug:   Resolved | WorksForMe
(Reporter)

Comment 2

14 years ago
Resolving bug.  Problem does not occur in Mozilla 1.7.5 suite or Thunderbird 1.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.