URL won't update after canceling confirm multi-tab closing dialog

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: nickz1, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If I click on the close box with multiple tabs open and then click Cancel on the
"confirm close" dialog, the URL in the location bar no longer changes when I
switch tabs or create new tabs but continues to show the URL of the tab that was
active when I dismissed the warning dialog.

Reproducible: Always
Steps to Reproduce:
1. (Warn on closing a window with multiple tabs open) must be set
2. Open multiple URLs in tabs
3. Click the close box on the browser window.
4. Click Cancel in response to the warning dialog that appears.

Actual Results:  
URL displayed in location bar is now stuck on the one that was displayed prior
to the dialog appearing, regardless of switching or opening new tabs.

Expected Results:  
Correct URL should be displayed when switching or opening new tabs.

Default theme.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

Theme is less likely to matter than extensions: got any installed? Do you still
see it in a fresh profile, without any extensions?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
I was running a handful of extensions. Booting in safe mode made the problem go
away so I went through my list one by one and found that Translate 0.6.0.4 (by
Paul Grave) seems to be the culprit. Removed it on my other machines and they
are working normally now too.

Good enough; be sure to let him know about the extension bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.