Crash in XPCONECT.DLL or GKLAYOUT.DLL - Profile moved to network drive

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Marcus von Cube, Assigned: Blake Ross)

Tracking

({crash})

1.0 Branch
x86
OS/2
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

After I moved my profile to a network drive (manually by editing profiles.ini)
FF became unstable. Two crashes are reported in POPUPLOG.OS2 (see below). I
moved the profile back to a local drive and the problem seems gone.

Reproducible: Sometimes
Steps to Reproduce:
1. move profile to a network drive
2. edit profiles.ini: Isrelative=0, Path=k:\daten\....
3. browse (e. g. www.sap.com)

Actual Results:  
crash

Expected Results:  
smooth operation

I'm running eCS 1.1 (German)

------------------------------------------------------------

12-08-2004  13:09:52  SYS3175  PID 00a1  TID 0001  Slot 004a
G:\MOZILLA\OS2\FIREFOX\FIREFOX.EXE
c0000005
1d4df092
P1=00000001  P2=0000f3cc  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=0000f3c4  EBX=015b60a8  ECX=00000001  EDX=015b6080
ESI=015b6000  EDI=ffffffff  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d4df092  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0011f704  SSACC=f0f3  SSLIM=ffffffff
EBP=0011f72c  FLG=00012212

XPCONECT.DLL 0001:0001f092

------------------------------------------------------------

12-08-2004  13:17:31  SYS3175  PID 00a2  TID 0001  Slot 004a
G:\MOZILLA\OS2\FIREFOX\FIREFOX.EXE
c0000005
1386f0ce
P1=00000001  P2=0000f482  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=0000f47a  EBX=01635f60  ECX=00000002  EDX=0000f482
ESI=01636060  EDI=012fe680  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1386f0ce  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0011f308  SSACC=f0f3  SSLIM=ffffffff
EBP=0011f31c  FLG=00012212

GKLAYOUT.DLL 0001:001bf0ce

Updated

14 years ago
Keywords: crash

Comment 1

14 years ago
is Talkback available on os/2? if yes, please send reports and post talkback ids
here. thanks.
Version: unspecified → 1.0 Branch
OS/2 doesn't have talkback.  We only have talkback on official Windows/Linux/OS
X builds.

Comment 3

14 years ago
I have tested this problem with OS/2 and Firefox 20041207 build. I could not
recreate the problem. The steps I have followed are :
1. Install Firefox.
2. Create a profile called "test" in C:\temp1 directory.
3. Start Firefox.
4. Close Firefox.
5. Open profiles.ini file and change C:\temp1 to W:\temp1... Where W: is a
network drive. and Save profiles.ini file.
6. Copied C:\temp1 to W:\temp1 with xcopy command.
7. Restart Firefox.  I did not see any crash.

Please Answer the following questions:
1. Is the problem recreatable on OS/2 or eCS alone?
2. Is the problem Consistent?
3. Please let me know if there is any change in the recreation steps.

Comment 4

14 years ago
I couldn't recreate it either, but I don't have a network drive to test.

The procedure of Marcus and Muni seems to be different in that Marcus _moved_
the profile while Muni still has the old path. Perhaps there is something in the
profile that still accesses the old location (like the cache path)?

Comment 5

14 years ago
Peter,
  I have also tried recreation by performing c:\rm -rf temp1 (i.e. removing
c:\temp1 directory) start the Firefox in a fresh window. Still I could not
recreate the problem. Please put more details to continue working on this problem. 

Comment 6

13 years ago
WFM per debugging and lack of reporter input.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.