If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Typeahead find strangely reset after page change

RESOLVED DUPLICATE of bug 255442

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 255442
13 years ago
9 years ago

People

(Reporter: Nicolas George, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041207 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041207 Firefox/1.0+

With a CVS trunk build from last night, there is a strange (and
non-deterministic) typeahead find behaviour when browsing from page to page:
after selecting one link with typeahead find, the typeahead find does not find
valid links on the next page. This will be clearer with the "steps to reproduce".

Reproducible: Sometimes
Steps to Reproduce:
1. start from a fresh profile (altough a fresh window or tab should be enough);
2. "begin finding when you begin typing" on;
3. go to <URL: http://www.mozilla.org/ > and click on the page to set the focus;
4. type "all pro" then enter;
5. type "fir";
6. wait some tipe, or hit backspace or escape, and then retype "fir".

Actual Results:  
Step 4 selects the "all products" links and opens the <URL:
http://www.mozilla.org/products/ >. This is fine.
At step 5, the typeahead find rings the bell to signal a "not found" error.
At step 6, the typeahead find finds the "Firefox" link.

Expected Results:  
The typeahead find should have found the "Firefox" link at step 5.

gcc, gcc version 3.3.4 (Debian 1:3.3.4-13), -Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -Wno-long-long -pedantic -pthread -pipe

c++, gcc version 3.3.4 (Debian 1:3.3.4-13), -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments: --enable-application=browser --enable-crypto
--enable-optimize --enable-optimize=-O3 --disable-debug
--enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --disable-tests
--enable-svg --enable-svg-renderer-libart --disable-ldap --disable-installer
--enable-strip --disable-mailnews --disable-composer --prefix=/opt/firefox-20041207

Updated

13 years ago
Assignee: aaronleventhal → firefox
Component: Keyboard Navigation → Find Toolbar / FastFind
QA Contact: jruderman

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 255442 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.