Mislabeled preference option (graphic emoticons => superscript)

RESOLVED WONTFIX

Status

Thunderbird
Preferences
--
minor
RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: Ryan Reich, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Thunderbird/1.0

The option "Display emoticons as graphics" in Edit/Preferences/Display is rather
misleading, as it has other side effects unrelated to emoticons.  For example,
enabling this option also causes Thunderbird to render text such as a^2 as a
superscript, which may not be desirable in cases like a^12, which results in
only the 1 being written superscript.  Either fix the behavior or change the
label, please.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
(In reply to comment #0)
> enabling this option also causes Thunderbird to render text such as a^2 as a
> superscript

So *that'* how you make that work!  I always have emoticons turned off, and 
couldn't figure out why I could never see the superscripting that other bugs are 
filed around.


> which may not be desirable in cases like a^12, which results in
> only the 1 being written superscript.  

I am seeing multiple digits be raised:
  x^1234567890  raises all ten digits
but:
  x^3.14        only raises the 3
  x^3a          doesn't raise anything


Are there any other rendering features besides superscripting that get turned on 
with that preference, to your knowledge?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

13 years ago
> a^12, which results in only the 1 being written superscript

Not true.


I think fixing this bug would overcomplicate the UI for almost no use. The only
option I see is to create a new pref (in this case, makes code larger and
probably slower) or to entirely remove the features. Marking WONTFIX (valid bug,
but decided against).

> Are there any other rendering features besides superscripting that get
> turned on with that preference

Yes, only minor ones:

- superscript (as discussed)
- +/-
- \f = formfeed (spoiler?)

<http://lxr.mozilla.org/seamonkey/source/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp#902>
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Updated

13 years ago
Severity: trivial → minor
Summary: Mislabeled preference option → Mislabeled preference option (graphic emoticons => superscript)

Comment 3

13 years ago
*** Bug 289241 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.