Implement AOL PassCode in Thunderbird

RESOLVED WONTFIX

Status

Thunderbird
Account Manager
--
enhancement
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: Ronan Magee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using an AOL account with Tb that has a PassCode associated with it there
is no provision to enter the pass code when checking for mail.  As a result of
this the mail checking process fails due to incorrect password.

Currently TB does this:
1. Check mail
2. Ask for password

... incorrect password


The correct operation of TB should be ...
1. Check mail
2. Ask for password
3. Ask for PassCode
4. Display mails

Reproducible: Always
Steps to Reproduce:
1.Create account
2.Click Get Mail
3.Enter Password

Actual Results:  
TB comes back with a password error and the mails cannot be checked.

Expected Results:  
TB should have provided the option to enter the 6 digit AOL PassCode and then go
on to display the new emails.

AOL now offer all members this PassCode option.  More and more members will sign
up to PassCode and this will limit them from using TB as a means of getting email.

More can be found on AOL Pass Code at these locations:
 http://help.channels.aol.com/article.adp?catId=6&sCId=415&sSCId=4090&articleId=217623

http://www.rsasecurity.com/press_release.asp?doc_id=5033
(Reporter)

Comment 1

13 years ago
Another open source project has been able to implement the AOL SecurID token
successfully.

The gAIM Messenger program will have support for this during the sign on process
in its next major release.

Maybe something like this can be added to TB?

Contact me if you would like more info regarding the functionality in gAIM for
securID support,

regards,

Ronan
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

13 years ago
Still no option to prompt for AOL Pass Code when checking mail
Severity: critical → enhancement
Summary: Not prompted to enter AOL PassCode when checking my mail - account is then denied → Implement AOL PassCode in Thunderbird

Comment 4

12 years ago
Please implement Passcode support.  It shouldn't take a flock of users to ask you to implement an enhancement that obviously prohibits the use of your product by a significant number of AOL members who would love to use the program.

All AOL employees and many Time Warner employees are bound by secureid (aka passcode), in addition to a growning number of AOL members.  If you have seen the AOL Mac client, you can appreciate my appeal to add passcode support.

rock on,

KD
(Reporter)

Comment 5

12 years ago
There is away around this for now ...

password/securID

Yep - the ' / ' is needed e,g, abcdef9876/123456

To get it to work you have to do:

Tools --> Account Settings from TB Menu

Click 'Server Settings from the left hand panel'

In the right hand pannel make sure the following is correct:

Server Name is: imap.aol.com
Port: 993

Under Security Settings section in right hand pannel make sure SSL is ticked.

Move back to the left pannel and go to Out Going Server (SMTP):

In the right hand side click Add ...

Enter the following info:
Sever name: smtp.cs.com
Port: 25

Under the Security and Authentication section:
Tick the box - Use Name and Password
Enter your aol username (without @aol.com)

In the Secure Section tick TLS, if Available

This should allow you send and receive mail through TB.

When sending mail you may be prompted to enter your password/securID
once every 15mins, this is because the securID expires.

Any problems let me know,

Ronan
QA Contact: account-manager

Updated

10 years ago
Assignee: mscott → nobody
This might be a great idea to implement as an extension. Did any of you ever posted the idea to extensions developers ?
(Reporter)

Comment 7

9 years ago
No, I have since ditched my AOL account and this has went off my radar.  Feel free to pick up and progress.
(In reply to comment #6)
> This might be a great idea to implement as an extension. Did any of you ever
> posted the idea to extensions developers ?

Best implemented in an extension. -> WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.