The default bug view has changed. See this FAQ.

"Attached" message/rfc822 not shown in attachment panel, when Inline Display is off

RESOLVED FIXED in Thunderbird 14.0

Status

MailNews Core
Attachments
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: seschu_mail2, Assigned: squib)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
Thunderbird 14.0
testcase
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Thunderbird Version 1.0 (20041206)

If a mail contains an email (eml file) as attachment and the "Show inline" from
the "View" menu is NOT activated the attachment (the mail) is not displayed at all. 

Reproducible: Always
Steps to Reproduce:
1. Send a mail with email as attachment to you
2. Uncheck the "Show inline" from the "View" menu
3. Open the mail



Expected Results:  
The attachment field should be present to open it

Comment 1

13 years ago
I am unable to reproduce this problem with TB 1.0, Win2K -- messages with an 
attached email message show the attachment pane, with the attachment visible 
therein.

Comment 2

12 years ago
No response from reporter; =>WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 3

12 years ago
Reopening; reviewing my email, I see that I did receive a response from 
reporter.  Please do not send mail in order to respond to queries in a bug; use 
the bug's webpage.

I could not get your sample message to work correctly, probably due to problems 
copying and pasting.  If you still have that message on hand, please do the 
following:  Save it to disk as a .EML file; then attach the file to this bug 
using the Create New Attachment link above.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

12 years ago
Created attachment 174524 [details]
Mail with attachment

Here is another file that shows the describes bug. I confirmed this mail to
still contain the failure ;-(

Comment 5

12 years ago
OK, I see this.  Reproduced with TB 1.0, Moz 1.8b-0120, Win2K.

The issue is seen because the message has this:
  Content-Type: message/rfc822
After the headers of the message stop, the headers of the "attached" message 
start.  This is unlike normal messages with attachments, whose type is typically 
multipart/mixed; in this case, the message body *is* the attachment.

With Display Attachments Inline turned on, the display is a blank body, followed 
by an attachment divider, followed by the message/rfc822 part as it would be 
seen as a regular attachment; and the icon appears in the attachment panel to 
allow the item to be accessed.

But with Display Attachment Inline turned *off*, the message is completely 
blank, with no attachment panel -- just as reported.

Compare to attachment 61294 [details] (from bug 2920) -- there, the top-level Content-Type 
is image/jpeg.  If Display Attachments Inline is off, the item does appear in 
the attachment panel.

Moving this to Core:Attachments, but I suppose it might be a MIME issue as well.

See also bug 234980.
Assignee: mscott → sspitzer
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → MailNews: Attachments
Ever confirmed: true
OS: Windows 2000 → All
Product: Thunderbird → Core
Hardware: PC → All
Summary: Attached Email not is displayed → "Attached" message/rfc822 not shown in attachment panel, when Inline Display is off
Version: unspecified → Trunk
Blocks: 269826
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
QA Contact: attachments
Product: Core → MailNews Core

Updated

7 years ago
Duplicate of this bug: 381544
Confirmed also with latest 

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4pre) Gecko/20100410 Lightning/1.0b2pre Lanikai/3.1b2pre ID:20100410032217

It's very annoying: any chance to fix it for 3.1 relase?

Set request to mark it wanted-thunderbird3.1
status-thunderbird3.1: --- → ?
Keywords: testcase

Comment 9

7 years ago
I have received exactly this kind of email from Delta airlines and have the
same problem.

If I have "Display attachments inline" unchecked, the message body is
completely blank and there is no indication at _all_ that there is an
attachment with this email.

In general I don't want to show attachments inline and there should be
something in the message header area that indicates there are attachments not
displayed -- there should be a list of the attachments and I should be able to
open them each individually.
(In reply to comment #8)
> Set request to mark it wanted-thunderbird3.1

Not going to want for a specific release.
status-thunderbird3.1: ? → ---
(Assignee)

Comment 11

5 years ago
Taking. This is easy enough to fix, but I'm going to write tests before I upload my patch.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
(Assignee)

Comment 12

5 years ago
Created attachment 613217 [details] [diff] [review]
Fix this, and count the size of RFC 822 bodies

This patch fixes the issue in the bug, and also properly counts the size of the RFC 822 body part. You'll need to apply the patch in bug 736881 first for the tests to pass.
Attachment #613217 - Flags: review?(dbienvenu)

Updated

5 years ago
Attachment #613217 - Flags: review?(dbienvenu) → review+
(Assignee)

Comment 13

5 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/e84b162968c7
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 14.0
You need to log in before you can comment on or make changes to this bug.