name=value pairs are submitted in wrong order when table containing form fields is dynamically rearranged

RESOLVED DUPLICATE of bug 204784

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 204784
13 years ago
13 years ago

People

(Reporter: Justin Watt, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
When the rows in a table are rearranged using JavaScript/DOM (see URL), and the
table cells in those rows contain input boxes, Firefox submits the input boxes
to the server in the wrong order, rather than in the dynamically rearranged order.

The good news is that they are submitted in a consistently wrong order, as
opposed to random order. It appears that Firefox chooses to submit the
unmodified nodes first, followed by the rearranged nodes (in this case rows). 

This behavior only seems to occur with form fields inside table elements whose
DOM is modified. Rearranging loose form fields inside a DIV for instance does
not exhibit this behavior. IE6 does not exhibit this behavior.
Please test trunk builds before filing core bugs.  This has been fixed since
October.

*** This bug has been marked as a duplicate of 204784 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.