If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

style-parameter of <input type=file> does not work

RESOLVED DUPLICATE of bug 52500

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 52500
13 years ago
13 years ago

People

(Reporter: Henrik Thesing, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

The style-parameter of the <input type=file> - Tag doesn't work correctly.

<input name="test" type="text" id="test" style="width: 200px; font-size: 12px;">
# works fine
<input name="pic" type="file" id="pic" style="width: 200px; font-size: 12px;">
#does not work




Reproducible: Always
Steps to Reproduce:
1. create a html-page with a form-tag
2. include a file-upload 
3. include a style-parameter with different widths, font-sizes etc.

Actual Results:  
The width-parameter seems to be interpreted correctly, but the font-family,
font-size etc. does not change. The Search-Button doen not apper behind the
input-field when the width-parameter is set.

Expected Results:  
Interprete the style-parameter of the <input type=file> - Tag as in other
input-type-fields.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.