firefox (and mozilla web browser) incorrectly handles <textarea/> tag

RESOLVED DUPLICATE of bug 162653

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 162653
14 years ago
14 years ago

People

(Reporter: Martin 'Nexus' Mlynář, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

if I use collapsed notation of empty <textarea></textarea> tag (<textarea/>,
firefox handles it as "not closed" tag
and throws in rest of whole xhtml code as text

Reproducible: Always
Steps to Reproduce:
1. uses <textarea /> anywhere in html code
2. try to display it with firefox or mozilla web browser
3. see and try to validate the page at w3.org

Actual Results:  
I've seen a textarea element with a rest of my html code in it
(http://www.smoula.net/download/bug.jpg)


Expected Results:  
wanted to see an empty textarea element ;)

maybe a bug in gecko
I've also tried this on cvs version (yesterday evening - 12. Dec 2004) with
similar results

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout: Form Controls
Keywords: testcase
OS: Linux → All
Product: Firefox → Core
QA Contact: firefox.general → core.layout.form-controls
Hardware: PC → All
Version: unspecified → Trunk

Updated

14 years ago
Assignee: nobody → parser
Component: Layout: Form Controls → HTML: Parser
QA Contact: core.layout.form-controls → mrbkap

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 162653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.